Модуль каталог статей

Тема в разделе "DLE", создана пользователем inmy, 12 дек 2012.

Информация :
Актуальная версия DataLife Engine 11.1
( Final Release v.11.1 | Скачать DataLife Engine | Скачать 11.1 demo )
Нужно ли обновляться | Как обновиться | Изменения в шаблонах
> Нет русских символов <
[Приватная тема DLE (Все подробности в ЛС к модератору раздела)]

Версии 10.0 и ниже - уязвимы!

Локализации | F.A.Q. | Внешний вид
Правила раздела | Правила форума
Обсуждение хайда карается баном!
В каждом сообщении указывайте версию DLE, которого они касаются!
Модераторы: killoff
  1. inmy

    inmy

    Регистр.:
    13 апр 2012
    Сообщения:
    296
    Симпатии:
    200
    Случайно надыбал модуль каталога статей на одном из своих хардов,так как я давно уже не занимаюсь разработками и правками модулей,решил выложить и поделиться с знатоками и пользователями нуледа,выкладываю архи каков он есть,полного описания и скрина нет у него.
    Модуль содержит:
    1. категории
    2. доп поля
    3. свой шаблон
    4. чпу
    5. сайтмап для гугла
    6. банеры
    7. шаблоны имеил сообщений
    8. управление группами пользователей
    9. Поиск и замену слов
    плюс описание из инструкции по установке:

    Разработчик: Usoft
    Версия модуля: 1.3
    ошибка которая выскакивает если добавлять статью через админку:
    PHP:
    Parse errorsyntax errorunexpected T_ENCAPSED_AND_WHITESPACEexpecting T_STRING or T_VARIABLE or T_NUM_STRING in Z:\home\test7.ru\subdomain\engine\articles\admin\modules\xfields.php on line 49 
    если будет писать что вы не имеете доступ в данный раздел,то нужно заменить в файлах админки модуля:
    PHP:
    if( ! $user_group[$member_id['user_group']]['admin_articles_add'] ) {msg_articles"error"$lang['index_denied'], $lang['index_denied'] );}
    на следующий код:
    PHP:
    if ($config['version_id'] < "7.5"$member_id['user_group'] = $member_db[1];
          else
            
    $member_id['user_group'] = $member_id['user_group'];
       
    if (
    $member_id['user_group'] != 1){ msg("error"$lang['opt_denied'], $lang['opt_denied']); }
    Ссылка на скачивание модуля:
     
  2. palbanec

    palbanec

    Регистр.:
    2 июл 2010
    Сообщения:
    455
    Симпатии:
    28
    не где не нашел, под какую версию. Вдоке только увидел <8.2
     
  3. inmy

    inmy

    Регистр.:
    13 апр 2012
    Сообщения:
    296
    Симпатии:
    200
    данный модуль под версию 8.х,для работы на линейке 9.х и 10.х нужно сделать много правок,так как там всё устаревшее по функциям
     
  4. stanislavsss

    stanislavsss Постоялец

    Регистр.:
    28 ноя 2012
    Сообщения:
    87
    Симпатии:
    2
    Или же попробовать этим способом http://coderlaba.com/index.php?action=mobiledisable
     
  5. killoff

    killoff CD тихо, и не DVD меня ;)

    Moderator
    Регистр.:
    13 май 2008
    Сообщения:
    2.015
    Симпатии:
    679
    Рассмешил... а каким образом создание htaccess изменит структуру обращения к БД в модуле а также другие изменения в исходниках двига? :lol:
    Если бы все было так просто то все бы обновлялись всегда до актуальной версии.
     
    Forza.Baron и Горбушка нравится это.
  6. stanislavsss

    stanislavsss Постоялец

    Регистр.:
    28 ноя 2012
    Сообщения:
    87
    Симпатии:
    2
    А вы не смейтесь а лучше спросите у автора того поста, что опубликовал информацию на том сайте, я нашёл инфу и ей просто поделился!
     
  7. Горбушка

    Горбушка Ищу её...

    Регистр.:
    2 май 2008
    Сообщения:
    3.035
    Симпатии:
    2.036
    Через htaccess можно поправить только настройки Apache. Не более. И описанная по ссылки статья - бред недоучки, который увидел htaccess с запретом на просмотр содержимого папки и снёс его, не задумавшись о том, для чего это было сделано.

    Ещё раз. Модули необходимо переписывать и обновлять, а не удалять защиту из ДЛЕ и пытаться костылями заставить что-то работать.

    killoff, +1.
     
    killoff и Forza.Baron нравится это.
  8. sdfrb

    sdfrb Создатель

    Регистр.:
    16 апр 2012
    Сообщения:
    12
    Симпатии:
    2
    К то то может данный мод поправить чтоб работал на версиях начиная с 9.8 ?