1. Уважаемые пользователи, прежде чем ответить в теме или создать новую,
    внимательно ознакомьтесь с правилами раздела

    Кому лень работать или руки не оттуда - пользуйтесь услугами специалистов
  2. Не задавайте глупых вопросов "Посоветуйте какой-нибудь компонент.."

    Есть JED!!! Ищите там!!!

Обсуждение Joomla 3.0

Тема в разделе "Joomla", создана пользователем Nagibator665, 28 сен 2012.

Информация :
  • Уважаемые пользователи, прежде чем ответить в теме или создать новую, внимательно ознакомьтесь с правилами раздела
  • Не задавайте глупых вопросов "Посоветуйте какой-нибудь компонент.." Есть JED!!! Ищите там!!!
  • Аналоги ищите там же - на JED!!!
  • Новая версия? - У кого будет - тот выложит!
Статус темы:
Закрыта.
Модераторы: arman29, DMS, Genk0, NightHunter
  1. Nagibator665

    Nagibator665

    Заблокирован
    Регистр.:
    27 авг 2012
    Сообщения:
    257
    Симпатии:
    78
    .
    Joomla 3.0 является выпуском со стандартным временем поддержки (6 меcяцев). Для тех кому не столь важны нововведения продолжается выпуск корректирующих обновлений для ветки 2.5, отнесённой к категории версий с длительным сроком поддержки (до весны 2014 г.). Поддержка старой LTS-ветки Joomla 1.5 будет прекращена в ближайшее время.
    Среди добавленных в Joomla 3.0 новшеств:
    • Интеграция JavaScript-фреймворка Bootstrap в пакет jui, разработанного компанией Twitter;
    • Новые шаблоны для административного интерфейса, адаптированные для использования на мобильных устройствах;
    • Новый фронтэнд Protostar, созданный с использованием JavaScript-фреймворка Bootstrap;
    • Обновление шаблона Beez3 для людей с ограниченными возможностями;
    • Новый, упрощённых до трёх шагов, процесс установки;
    • Драйвер для обеспечения поддержки работы сайтов на базе Joomla 3.0 с использованием СУБД PostgreSQL;
    • Драйвер для работы с Memcached;
    • Задействование JFeed вместо SimplePie для управления новостными лентами;
    • Поддержка установки языковых пакетов непосредственно из менеджера дополнений;
    • Включение по умолчанию группы для гостевого входа;
    • Новый модуль для показа статистики в административном интерфейсе;
    • Обновление TinyMCE до версии 3.5.6
    • Выполнение работы по чистке устаревшего неиспользуемого кода, файлов и полей в БД. Стандартизация стиля написания кода;
    • Улучшение реализации "умного поиска";
    • Использование unit-тестирования CMS;
    • Поддержка в модуле menu кастомизированных активных элементов меню.
    p.s. только что узнал о его выходе. Не думал что так быстро выйдет 3я ветка
     
  2. al-teen

    al-teen Постоялец

    Регистр.:
    1 сен 2012
    Сообщения:
    75
    Симпатии:
    5
    Ну, это лишь первый стабильный релиз ветки. Можно сказать, переходная версия. Избавление от того же мутулза не может пройти быстро. Дают возможность разработчикам переписать свои расширения на JQuery. Обновление из админки с 2.5 пока не работает, будет поддержано с 3.5 версий, может чуть раньше. Так же как и полное выпиливание коровьего фрэймворка. Русская локализация появится в ближайшее время, ребята уже занимаются ею.

    Из личных впечатлений: меньше грузит систему и браузер, непривычно, но в принципе ничего особо нового в элементах управления админкой нет. Просто иначе все расположено. Достаточно шустро работает. Явных багов пока не заметил, ковыряю код дальше. После обновления ни один сторонний компонент, кроме Akeeba Backup, не работает - оно и понятно, пока обновлений для 3.0 у них нет.
     
  3. CAPAXA

    CAPAXA

    Регистр.:
    7 июн 2007
    Сообщения:
    917
    Симпатии:
    544
    Да сколько ж можно!?
    1.0 !== 1.5 !== 1.7 !== 2.5 !== 3.0
    Что им так не ймётся, то. Все время мигрировать с версии на версию?
     
  4. Nagibator665

    Nagibator665

    Заблокирован
    Регистр.:
    27 авг 2012
    Сообщения:
    257
    Симпатии:
    78
    Тоже задаюсь этим вопросом. только начали переползать на 2.5, как уже 3.0 сделали. Некоторые еще и на 1.5 спокойно сидят.
     
  5. mr_crossy

    mr_crossy Постоялец

    Регистр.:
    25 авг 2012
    Сообщения:
    84
    Симпатии:
    39
    Как будет осуществляться переход? 2.5 сносить под ноль и ждать расширений под 3.0?
     
  6. al-teen

    al-teen Постоялец

    Регистр.:
    1 сен 2012
    Сообщения:
    75
    Симпатии:
    5
    На данный момент есть пакет для обновления с 2.5. Скачать можно там же, где и фуллпак. Обновляем путем замены файлов - кидаем апгрейд-пак в корень сайта, соглашаясь на замену.

    Файрфокс обновляется еще чаще. Но почему то это никого не тревожит.
     
  7. CAPAXA

    CAPAXA

    Регистр.:
    7 июн 2007
    Сообщения:
    917
    Симпатии:
    544
    У меня после 12-ой версии Файрфокса не слетело ни одного дополнения.
    Чего и желаю Джумле.
     
  8. al-teen

    al-teen Постоялец

    Регистр.:
    1 сен 2012
    Сообщения:
    75
    Симпатии:
    5
    С 1.6 по 2.5 тоже не слетело ничего, была обратная совместимость. В 3.0 обновили платформу. А в рыжем собаке начиная от версии 12 лично я задолбался удалять нерабочие улучшайзеры Файрбага, YSlow достаточно долго не работал. Разве что последние две ветки все нормально работало. Хотя вру, FireShot целую ветку вообще не работал. Завидую белой завистью тем, у кого ничего не слетало, или кто ничего не ставит на собаку. :crazy:
     
  9. baser

    baser Создатель

    Регистр.:
    18 июн 2008
    Сообщения:
    45
    Симпатии:
    15
    По умолчанию, Joomla не даст вам обновиться до 3.0, пока вы не активируете эту настройку в компоненте обновлений Joomla! (Компоненты -> Обновление Joomla! -> Настройки -> Источник обновлений -> Дистрибутивы Joomla с краткосрочной поддержкой).
    Если по какой причине вы изменили эту настройку и хотите продолжать использовать Joomla 2.5, то измените её обратно на "Дистрибутивы Joomla с длительным периодом поддержки". После этого вы будете получать обновления только для Joomla 2.5.
     
  10. mr_crossy

    mr_crossy Постоялец

    Регистр.:
    25 авг 2012
    Сообщения:
    84
    Симпатии:
    39
    Ради интереса поставил на локалхост 2.5 квикстартом (обновил до 2.5.7), соответственно, это тема и штук 5 расширений к ней. Выставил "Дистрибутивы Joomla с краткосрочной поддержкой" в источниках обновлений и скачал пакет обновлений, который закинул в корень. Результат - сплошные ошибки. Думаю попробовать поставить поверх чистой 2.5.7 без расширений, ну а потом 3.0 с нуля. Люблю экспериментировать...
     
Статус темы:
Закрыта.