1. Уважаемые пользователи, прежде чем ответить в теме или создать новую,
    внимательно ознакомьтесь с правилами раздела

    Кому лень работать или руки не оттуда - пользуйтесь услугами специалистов
  2. Не задавайте глупых вопросов "Посоветуйте какой-нибудь компонент.."

    Есть JED!!! Ищите там!!!

Обсуждение Есть ли резон обновляться 1.5—2.5

Тема в разделе "Joomla", создана пользователем yhnyhn, 16 сен 2012.

Информация :
  • Уважаемые пользователи, прежде чем ответить в теме или создать новую, внимательно ознакомьтесь с правилами раздела
  • Не задавайте глупых вопросов "Посоветуйте какой-нибудь компонент.." Есть JED!!! Ищите там!!!
  • Аналоги ищите там же - на JED!!!
  • Новая версия? - У кого будет - тот выложит!
Статус темы:
Закрыта.
Модераторы: arman29, DMS, Genk0
  1. yhnyhn

    yhnyhn Постоялец

    Регистр.:
    8 июл 2009
    Сообщения:
    61
    Симпатии:
    7
    Приветствую.
    Мучаюсь уже третий день. В числе прочего поставлена задача заказчиком обновить версию Жумлы! с 1.5 до 2.5.

    (после предварительного создания всех бэкапов) Jupgrade, на сервере глох на полпути, как выяснилось позже 128 мб памяти не хватало - база огромная, выкачав, все сработало, но криво - из директории не запускается. Детали озвучивать не буду, но старый программист многое, с**а, завязал на себя

    Подскажите, насколько страшно в плане безопасности и произодительности оставлять сайт на системе ветки 1.5 (обновил до последней возможной версии)? Учитывая, что функционал наращиваться не будет, расти будет только контент.

    Спасибо
     
  2. arma7

    arma7

    Регистр.:
    5 ноя 2010
    Сообщения:
    163
    Симпатии:
    36
    Я бы не делал. Хоть и не поддерживается линейка 1,5 но реальных взломов через lдыры CMS я не встречал. Тем более если всё устраивает и добавляться будет только контент.
     
  3. Aleks1979

    Aleks1979 Постоялец

    Регистр.:
    6 май 2012
    Сообщения:
    51
    Симпатии:
    25
    Вот тут вы правы! Ни обновлений, ни поддержки, ни новых компонентов... ТС, если есть хоть малейшая возможность обновиться - не раздумывайте... Это сейчас ваши заказчики не хотят ничего менять, а через пол-года все может измениться...
     
  4. Sobesednic

    Sobesednic Создатель

    Регистр.:
    25 мар 2012
    Сообщения:
    17
    Симпатии:
    31
    Пробовал на одном сайте обновиться, в итоге вернул все назад, потому что перенесло все криво.
     
  5. Airclaim

    Airclaim Постоялец

    Регистр.:
    2 май 2007
    Сообщения:
    116
    Симпатии:
    18
    У меня был такой же вопрос...
    Для себя решил оставить на 1.5, просто закачаю несколько компонентов на авось пригодиться. С кривизной согласен.
    Новое буду собирать на 3 сразу, пока жду...
    А ваши заказчики захотят 3 через пол года и что?
    Лучше на новом домене тогда и для сетки пригодиться)))
     
  6. mr_crossy

    mr_crossy Постоялец

    Регистр.:
    25 авг 2012
    Сообщения:
    83
    Симпатии:
    39
    Старое оставить старым, новое начинать с 2.5. Отсутствие поддержки - минус большой.
     
  7. shuran

    shuran

    Регистр.:
    4 июн 2010
    Сообщения:
    237
    Симпатии:
    70
    От добра добра не ищут. Если все работает то трогать не нужно, при переезде вылазят разные косяки, сами знаете. Тем более никаких доработок не планируется. Если конечно заказчик упрется то нужно делать, но объяснив ему все моменты перезда и поставив в известность по затратам времени и финансов. Так вроде дыр новых замечено не было серьезных, если немного позаботиться о безопасности то можно жить и на 1.5, еще не известно что в 2.5 может вылезти.
     
  8. al-teen

    al-teen Постоялец

    Регистр.:
    1 сен 2012
    Сообщения:
    75
    Симпатии:
    5
    Тут вопрос о безопасности следует начинать рассматривать с позиции "А кому нафиг нужен тот сайт, чтобы ломать его?" Крупный ресурс обновляется своевременно, мелочь всякую можно вообще не трогать и не подвергать себя (или клиента) приступам паранойи, связанной с какерами. Хотя обновляться все же стоит. Например хастинг обновит версию php в будущем и сайт встанет колом.
     
  9. Aleks1979

    Aleks1979 Постоялец

    Регистр.:
    6 май 2012
    Сообщения:
    51
    Симпатии:
    25
    А при чем тут "нужен сайт" или "не нужен"? Читайте внимательно:
    ТС, как вариант: SPtransfer (работает точно при переносе статей)

    Инструкция:
     
    mumins нравится это.
  10. dema8912

    dema8912 Писатель

    Регистр.:
    22 мар 2012
    Сообщения:
    7
    Симпатии:
    0
    Пробывал обновляться с версии 1.0 к 2.5, убил кучу времени, но это было оправдано. 1.0 конечно не 1.5. В принципе контент весь перенес с помощью джеапргрейт в начале на 1.5, а затем с 1.5 на 2.5, верстку перенес руками - это не сложно, самое страшное это было - сохранить все ссылки, вот здесь был настоящий ужас. Так что решать Вам. В принципе 1.5 нормально работает, и если Вы говорите, что база огромная, то контента много и если Вам нужно сохранить ссылки, то лучше оставаться на 1.5. Это мое мнение.
     
Статус темы:
Закрыта.