[Seven] Denwer не работает

Тема в разделе "Windows", создана пользователем Scaltro, 30 авг 2012.

Статус темы:
Закрыта.
Модераторы: ADMiNZ
  1. Scaltro

    Scaltro

    Регистр.:
    15 сен 2007
    Сообщения:
    1.092
    Симпатии:
    75
    Уважаемые пользователи помогите мне пожалуйста решить проблему, давненько установил себе денвер и давно им не пользовался, тут опять появилась надобность, но как оказалось он почему то оказался неработоспособным, апач вылетает выдавая следующее сообщение:

    [​IMG]

    Пошарив в сети, оказалось что ни я один сталкивался с подобной ситуацией, в основном говорят что скайп занимает порт 80, советовали проделать следующую операцию:
    Настройки=>дополнительно=>соединение=>Иcпoльзoвaть пopты 80 и 443 в кaчecтвe вxoдящиx aльтepнaтивныx галочку надо убрать, но не тут то было, после запуска денвера тоже самое выдаёт апач. Тогда нашёл ещё один вариант, посоветовали в файле httpd.conf по адресу usr\local\apache\conf сменить порт например на 8080, раскомментировал эту диррективу с заменой порта на 8080:

    Код:
    Listen $&{ip:-127.0.0.1}:$&{port:-8080}
    NameVirtualHost $&{ip:-127.0.0.1}:$&{port:-8080}
    <VirtualHost $&{ip:-127.0.0.1}:$&{port:-8080}>
      DocumentRootMatch "/home/(?!cgi-)(.*)^1/(?!cgi$|cgi-)(.*)"
      DocumentRootMatch "/home/(?!cgi-)(.*)/public_html^1"
      DocumentRootMatch "/home/(?!cgi-)(.*)/public^1"
      DocumentRootMatch "/home/(?!cgi-)(.*)^1/html/(.*)"
      DocumentRootMatch "/home/(?!cgi-)(.*)^1/domains/(?!cgi$|cgi-)(.*)"
      DocumentRootMatch "/var/www/html/(?!cgi-)~(.*)^1/(?!cgi$|cgi-)(.*)"
      DocumentRoot "$&"
      ServerName "%&/-www"
      ServerAlias "%&/-www" "%&/-www/www" $&{host:-}
     
      $&{directives:-}
     
      ScriptAlias /cgi/ "$^1/cgi/"
      ScriptAlias /cgi-bin/ "$^1/cgi-bin/"
    </VirtualHost>
    После чего апач стал выдавать следующее сообщение:

    [​IMG]

    Как всё же решить эту проблему? :thenks:
     
  2. dmx

    dmx

    Регистр.:
    22 июн 2011
    Сообщения:
    662
    Симпатии:
    526
    Отключи скайп торрент и т.д. - потом стартуй
     
  3. Scaltro

    Scaltro

    Регистр.:
    15 сен 2007
    Сообщения:
    1.092
    Симпатии:
    75
    Во время запуска денвера никаких запущенных приложений нет...
     
  4. Sunday

    Sunday

    Регистр.:
    13 дек 2009
    Сообщения:
    724
    Симпатии:
    314
    Можно снести денвер и установить заново. Дел на 5 минут.
     
  5. Scaltro

    Scaltro

    Регистр.:
    15 сен 2007
    Сообщения:
    1.092
    Симпатии:
    75
    Этот момент тоже уже учтён, стояла версия от 2000 хрен знает какого года, скачал новенькую, поставил, один фиг сообщение точ в точ тоже самое...
     
  6. Nagibator665

    Nagibator665

    Заблокирован
    Регистр.:
    27 авг 2012
    Сообщения:
    258
    Симпатии:
    79
    у тебя ошибка на 703 строке, в файле httpd.conf, вот он и не запускается. что там у тебя?
     
  7. Scaltro

    Scaltro

    Регистр.:
    15 сен 2007
    Сообщения:
    1.092
    Симпатии:
    75
    Код:
    Listen $&{ip:-127.0.0.1}:$&{port:-8080}
     
  8. Nagibator665

    Nagibator665

    Заблокирован
    Регистр.:
    27 авг 2012
    Сообщения:
    258
    Симпатии:
    79
    напиши: Listen 127.0.0.1:80
    или 8080
     
    Bezhev нравится это.
  9. Scaltro

    Scaltro

    Регистр.:
    15 сен 2007
    Сообщения:
    1.092
    Симпатии:
    75
    Установил: Listen 127.0.0.1:8080 апач вроде молчит, но страница http://localhost/denwer/ в хроме говорит: Ошибка. Ссылка не работает...
     
  10. Nagibator665

    Nagibator665

    Заблокирован
    Регистр.:
    27 авг 2012
    Сообщения:
    258
    Симпатии:
    79
    значит апач заработал.

    может url не такой у денвера.. я просто с ним не работал никогда... я предпочитаю сам собирать апач+пхп+мускул, т.е. конфиги сам собираю.

    p.s. а если попробовать просто localhost?
     
Статус темы:
Закрыта.