Помощь ошибка в перестроение публикаций

Тема в разделе "DLE", создана пользователем warayg, 5 июл 2012.

Информация :
Актуальная версия DataLife Engine 11.1
( Final Release v.11.1 | Скачать DataLife Engine | Скачать 11.1 demo )
Нужно ли обновляться | Как обновиться | Изменения в шаблонах
> Нет русских символов <
[Приватная тема DLE (Все подробности в ЛС к модератору раздела)]

Версии 10.0 и ниже - уязвимы!

Локализации | F.A.Q. | Внешний вид
Правила раздела | Правила форума
Обсуждение хайда карается баном!
В каждом сообщении указывайте версию DLE, которого они касаются!
Статус темы:
Закрыта.
Модераторы: killoff
  1. warayg

    warayg Создатель

    Регистр.:
    9 июн 2011
    Сообщения:
    11
    Симпатии:
    0
    Здравствуйте, подскажите плиз, что могло случиться с DLE 9.5, перестало работать "Перестроение публикаций", пару дней назад все работало, ни чего не менял, только добавлял новые новости, после нажатия "продолжить перестроение" выводит: Общее количество новостей: 56, обработано новостей: 0 ошибка отправки
     
  2. warayg

    warayg Создатель

    Регистр.:
    9 июн 2011
    Сообщения:
    11
    Симпатии:
    0
    Не ужели ни кто не сталкивался с таким? Чистил базу, удалил все новости, перестроение публикаций работало пока не добавил большую статью, потом снова перестало работать ((
     
  3. lift

    lift Читатель

    Заблокирован
    Регистр.:
    1 июл 2007
    Сообщения:
    2.226
    Симпатии:
    1.378
    Во первых тему твою наверное не замечали потому, что ты не потрудился префикс в названии поставить, а? Во вторых твою тему не замечали потому, что описания проблемы в ней 0: "у меня поломалось а что и как - гадайте сами, вы же телепаты.

    Предположу, что возможно лимитов php на выполнение скрипта перестало хватать. Или у тебя не переделанна под большие статьи база (поля короткой и полной новостей не LONGTEXT). Вариантов масса, пока ты не опишеш проблему номрально это будет гадание на кофейной гуще.
     
  4. warayg

    warayg Создатель

    Регистр.:
    9 июн 2011
    Сообщения:
    11
    Симпатии:
    0
    Извиняюсь, но не понимаю как подробнее проблему описать и о каком префиксе в названии поста идет речь? )) Установил DLE 9.5, заполнял статьями, все работало, так как я использую фильтр слов, то у меня много ссылок в тексте получается (Ключевое слово заменяется на ссылку к статье касающейся этого слова) и для того чтоб в старых статьях эти ссылки появились я и использую перестроение публикаций, чтоб их вручную не пересохранять, так вот, все работало, после добавления относительно большой статьи перестает работать перестроение публикаций. В базе заменил TEXT на LONGTEXT, не помогло. Сайт тестирую и заполняю пока локально, использую Денвер.
     
  5. lift

    lift Читатель

    Заблокирован
    Регистр.:
    1 июл 2007
    Сообщения:
    2.226
    Симпатии:
    1.378
    Обрати внимание на то, как называется тема сейчас и вспомни, как называлась. Можеш ткнуть кнопку создания темы новой и спосотреть на внимательне слева от поля ввода заголовка темы.
    Как подробнее писать создавая тему есть в правилах раздела в закрепленых темах. Как минимум версию ДЛЕ ты указал вот только в последнем посте.


    1) Денвер это, к сожалению, денвер. Попробуй скачать XAMPP http://www.apachefriends.org/en/xampp.html и повторить все на нем.
    2) Если ты говориш, чт окосяк в конкреной новости, попробуй повторить все удалив эту новость. Потом (если получится) накидай дальше новостей и попробуй снова. Если будет работать пробуй новость частями добавлять. Мне кажется причина может крыться либо в размере новости, либо во времени исполнения скрипта в денвере либо в каком либо левом знаке, присутствующем в новости. У тебя ср1251 или утф?
    3) 9.6 уже черти когда вышла. Попробуй в ней это сделать, возможно в 9.5 есть баг какой-то, который в 9.6 вылечили.
     
    warayg нравится это.
  6. warayg

    warayg Создатель

    Регистр.:
    9 июн 2011
    Сообщения:
    11
    Симпатии:
    0
    У меня cp1251. На XAMPP та же фигня, ставил 9.6, загружал статьи из бэкапа и тоже не работает перестроение ((
     
  7. lift

    lift Читатель

    Заблокирован
    Регистр.:
    1 июл 2007
    Сообщения:
    2.226
    Симпатии:
    1.378
    Давай конкретно:
    1) это пробелма с 1 статьей или с несколькими?
    2) если доваблять остальные статьи (много) то проблема не появляется а при добавлении этой - снова есть?
    3) если ты эту статью добавляеш по-абзацам, сохраняеш и перестраиваеш новости ты можеш найти то место, когда перестроение перестает работать?
    4) если пропустить проблемный абзац то новость добавляется и перестраивается корректно?
    Чтоб не флудить проверяй по пунктам все и напиши сразу все 4 ответа. И если все по пунктам работает и абзац косячный найден то может его имеет смысл переписать? Или проверить на предмет проблемных знаков (например исходник когда-то был юникодом с непечатным в cp1251 символом и т.п.?
    И попробуй версию с utf-8 поставить и конвертнуть базу в него, возможно проблема исчезнет.
     
  8. warayg

    warayg Создатель

    Регистр.:
    9 июн 2011
    Сообщения:
    11
    Симпатии:
    0
    Выложил сайт на хостинг, перелинковка не работала, вручную пересохранил все статьи и заработало ))) пипец. В чем был трабл, так и не понял.
     
Статус темы:
Закрыта.