[Помогите] Не генерируется wp-caption в картинках

Тема в разделе "Wordpress", создана пользователем Avrora, 8 июн 2012.

Статус темы:
Закрыта.
Модераторы: DzSoft, Sorcus
  1. Avrora

    Avrora Постоялец

    Регистр.:
    12 фев 2010
    Сообщения:
    73
    Симпатии:
    48
    Приобрел шаблон "Gonzo".
    Перейти по ссылке
    Все знают если в поле "Подпись" при добавлении изображения добавить текст, то wp автоматом выведет его при генерации страницы. Но к сожалению ничего подобного не выводит. Помогите придумать почему? Смотрел несколько других шаблонов, все нормально.
     
  2. ws256

    ws256

    Регистр.:
    15 июл 2009
    Сообщения:
    259
    Симпатии:
    63
    А какой код html у вас при вставке изображения? присутствует .wp-caption?
     
  3. Avrora

    Avrora Постоялец

    Регистр.:
    12 фев 2010
    Сообщения:
    73
    Симпатии:
    48
    HTML:
    <a href="http://g/wp-content/uploads/2012/06/1.jpg">
    <img class="alignnone size-full wp-image-58" alt="" src="http://g/wp-content/uploads/2012/06/1.jpg">
    </a>
    Отсутствует. Может перестала генерировать подпись из того что новая версия движка?
    Где посмотреть изменения в версиях wordpress?
     
  4. ws256

    ws256

    Регистр.:
    15 июл 2009
    Сообщения:
    259
    Симпатии:
    63
    У меня последняя 3.3.2 - все работает.
    Возможно Вы что то не так делаете? Или плагины новые?
    Попробуйте прописать вручную.
    HTML:
    
    [caption id="attachment_60524" align="alignnone" width="150" caption="текст подписи"]<a href="http://www/wp-content/uploads/2008/10/Bez-imeni-1.gif"><img src="http://www/wp-content/uploads/2008/10/Bez-imeni-1-150x150.gif" alt="" title="тайтл" width="150" height="150" class="size-thumbnail wp-image-60524" /></a>[/caption]
    
     
    Avrora нравится это.
  5. Avrora

    Avrora Постоялец

    Регистр.:
    12 фев 2010
    Сообщения:
    73
    Симпатии:
    48
    Да. Действительно. Вручную работает. Но хочется что-бы на автоматически вставлялся :rolleyes:
     
  6. ws256

    ws256

    Регистр.:
    15 июл 2009
    Сообщения:
    259
    Симпатии:
    63
    Это делает визуальный редактор.
    Два варианта, либо вы не правильно вставляете подпись в медиафайлах.
    Либо какойто плагин мешает. (отключать и пробовать)

    Еще вот что поробуйте, смените тему на дефолтную, если заработает, значит functions.php шаблона Gonzo прописан какой то код для визуального редактора, который не работает правильно.
     
  7. Avrora

    Avrora Постоялец

    Регистр.:
    12 фев 2010
    Сообщения:
    73
    Симпатии:
    48
    PHP:
    // Remove the image dimensions to make the theme responsive
    add_filter'post_thumbnail_html''remove_thumbnail_dimensions'10 );
    add_filter'image_send_to_editor''remove_thumbnail_dimensions'10 );
    А вот и оно в файле functions.php
    Я так понял придется отказаться от адаптивности.
     
Статус темы:
Закрыта.