ioncube + zend = error 500

Тема в разделе "Администрирование серверов", создана пользователем b0t, 20 май 2012.

Модераторы: mefish, stooper
  1. b0t

    b0t Создатель

    Регистр.:
    5 июл 2007
    Сообщения:
    32
    Симпатии:
    6
    никак не могу подружить Zend guard + ioncube loader, когда включаю вместе то на всех сайтах ошибка 500 а если по отдельности то все работает
    php-FastCGI

    php.ini
    zend_extension=/usr/lib/php5/ZendGuardLoader.so
    zend_extension=/usr/lib/php5/ioncube/ioncube_loader_lin_5.3.so

    лог

    Код:
    [Sun May 20 16:23:19 2012] [notice] Apache/2.2.16 (Debian) DAV/2 mod_fcgid/2.3.6 PHP/5.3.3-7+squeeze9 with Suhosin-Patch mod_ruby/1.2.6 Ruby/1.8.7(2010-08-16) mod_ssl/2.2.16 OpenSSL/0.9.8o configured -- resuming normal operations
    [Sun May 20 16:23:19 2012] [warn] long lost child came home! (pid 15132)
    PHP Fatal error:  [ionCube Loader] The Loader must appear as the first entry in the php.ini file in Unknown on line 0
    PHP Fatal error:  [ionCube Loader] The Loader must appear as the first entry in the php.ini file in Unknown on line 0
    PHP Fatal error:  [ionCube Loader] The Loader must appear as the first entry in the php.ini file in Unknown on line 0
    PHP Fatal error:  [ionCube Loader] The Loader must appear as the first entry in the php.ini file in Unknown on line 0
    PHP Fatal error:  [ionCube Loader] The Loader must appear as the first entry in the php.ini file in Unknown on line 0
    PHP Fatal error:  [ionCube Loader] The Loader must appear as the first entry in the php.ini file in Unknown on line 0
    PHP Fatal error:  [ionCube Loader] The Loader must appear as the first entry in the php.ini file in Unknown on line 0
    PHP Fatal error:  [ionCube Loader] The Loader must appear as the first entry in the php.ini file in Unknown on line 0
    PHP Fatal error:  [ionCube Loader] The Loader must appear as the first entry in the php.ini file in Unknown on line 0
    
     
  2. b0t

    b0t Создатель

    Регистр.:
    5 июл 2007
    Сообщения:
    32
    Симпатии:
    6
    Вопрос решен..

    Так не работает.
    [zend]
    zend_extension=/usr/lib/php5/ZendGuardLoader.so
    zend_extension=/usr/lib/php5/ioncube/ioncube_loader_lin_5.3.so

    А так работает
    [zend]
    zend_extension=/usr/lib/php5/ioncube/ioncube_loader_lin_5.3.so
    zend_extension=/usr/lib/php5/ZendGuardLoader.so
     
  3. Da1VeR

    Da1VeR Постоялец

    Регистр.:
    22 фев 2012
    Сообщения:
    128
    Симпатии:
    21
    Бррр.... как? только что у себя попробовал, переставил местами как у тебя в нерабочем варианте - работает... вариант:
    Так не работает.
    [zend]
    zend_extension=/usr/lib/php5/ZendGuardLoader.so
    zend_extension=/usr/lib/php5/ioncube/ioncube_loader_lin_5.3.so

    у меня все работает.... может что-то другое правил?
     
  4. b0t

    b0t Создатель

    Регистр.:
    5 июл 2007
    Сообщения:
    32
    Симпатии:
    6
    на Debian 5 x32 у меня тоже работал по разному а на CentOS 6.2 и Debian 6 именно х64 работает только если ioncube стоит первый и хз по чему так
     
  5. gorsgr

    gorsgr Постоялец

    Регистр.:
    25 апр 2014
    Сообщения:
    85
    Симпатии:
    16
    Спасибо! На CentOS 7 php5.4 получилось как только поменял местами, сколько времени мучался пока не доперло что расширения конфликтуют...