Не могу обновить nginx

Тема в разделе "Администрирование серверов", создана пользователем bat, 15 мар 2012.

Статус темы:
Закрыта.
Модераторы: mefish, stooper
  1. bat

    bat

    Регистр.:
    24 сен 2009
    Сообщения:
    975
    Симпатии:
    277
    Старый стоит, но хочу новый поставить, разу уже все начал переустанавливать, а он, сцуко, до конца не хочет устанавливаться и все тут, выдает:
    invoke-rc.d: initscript nginx, action "start" failed.
    dpkg: error processing nginx (--configure) :
    subprocess installed post-installation script returned error exit status 1
    configured to not write apport reports
    Errors were encountered while processing:
    nginx
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    Серв на Debian 6, уже все обновил кроме Nginx (((
     
  2. pointer

    pointer Создатель

    Регистр.:
    24 окт 2011
    Сообщения:
    14
    Симпатии:
    1
    версия nginx какая? как я понял вы ее сами собираете, а что мешает поставить с реп. недавно обновился с них до 1.0.12
     
  3. Alexandr3

    Alexandr3

    Заблокирован
    Регистр.:
    22 апр 2008
    Сообщения:
    429
    Симпатии:
    96
    Добавьте репы с сайта Сысоева в apt/sources.list, и четко укажите какую версию ставить.
     
  4. bat

    bat

    Регистр.:
    24 сен 2009
    Сообщения:
    975
    Симпатии:
    277
    дык я и так с репа ставил, но что-то пошло не так (вчера как раз вышел вышел nginx 1.0.14)
    Это сделано все, суть в том что nginx как не устанавливался так и не удалялся, оказалось что из-за того что куда-то пропал nginx.conf :nezn:, а ведь все делалось через apt-get и не более.
    Вобщем пришлось обратиться за помощью к mefish, там не все так просто оказалось, потом еще вылезли проблемы с апачем (его конфиг потом тоже пропал), вобщем мистика.
    mefish проблему устранил, всем спасибо за помощь.
     
Статус темы:
Закрыта.