Установить конкретную версию php и phpmyadmin на vps

Тема в разделе "Администрирование серверов", создана пользователем Sergo_Sev, 13 янв 2012.

Модераторы: mefish, stooper
  1. Sergo_Sev

    Sergo_Sev Творец

    Регистр.:
    14 июн 2008
    Сообщения:
    571
    Симпатии:
    187
    У меня на VPS debian стоял 5.2.6-1+lenny9, добавил репозитории и Обновился до 5.3.9-1~dotdeb.2, потом даунгрейдился до 5.2.17-0.dotdeb.0
    phpMyAdmin теперь вообще отсутствует на сервере, а через ISPmanager он не устанавливаетсяи показано, что он включен

    Обновился сначала так
    http://2centos.hostdot.ru/stat/kak_obnovit_php_na_ispmanager_plyus_debian.htm/
    После поставил более раннюю версию
    http://unixblog.org.ua/php/debian-squeeze-install-downgrade-to-php-5-2-17/

    Техподдержка пишет - мы не рекомендуем использовать репозиторий dotdeb, поскольку он не стабилен.

    Как вернуть phpMyAdmin и поставить например php5-5.2.6.dfsg.1-1+lenny10 ?
    Я в unix почти ничего не понимаю и делаю все по инструкции. Подскажите, где можно почитать про то как и что правильно ставить и где брать эти дистрибутивы и каких репозиториях.
     
  2. esche

    esche

    Регистр.:
    9 авг 2009
    Сообщения:
    359
    Симпатии:
    243
    Загляните в /etc/apache2/conf/ - там имеется что-то вроде phpmyadmin?
    phpmyadmin можно просто скачать и положить в нужный каталог (как общий для всех, так и для конкретного сайта) и прописать в .conf файле. либо в консоли apt-get install phpmyadmin
    А чем 5.2.17 не устраивает?
     
  3. Sergo_Sev

    Sergo_Sev Творец

    Регистр.:
    14 июн 2008
    Сообщения:
    571
    Симпатии:
    187
    Так, ладно...
    Тогда такой вопрос - я хочу установить конкретно
    PHP 5.2.6-1+lenny13
    phpmyadmin-2.11.8.1-5+lenny9

    Как это сделать?