Код лого. Alt и title в логотипе webasyst.

Тема в разделе "WebAsyst", создана пользователем gambiter, 10 ноя 2011.

Модераторы: mdss
  1. gambiter

    gambiter Писатель

    Регистр.:
    27 авг 2011
    Сообщения:
    5
    Симпатии:
    1
    Столкнулся с проблемой в выводе логотипа на вебасисте.
    Задача заменить alt и добавить title для логотипа вместо стандартного.
    Правлю файл published/SC/html/scripts/modules/test/class.test.php
    Следующую строку
    print '<a href="'.xHtmlSetQuery('?ukey=home').'"><img src="'.$logo_url.'" alt="'.xHtmlSpecialChars(CONF_SHOP_NAME).'" /></a>';
    Меняю на
    print '<a href="'.xHtmlSetQuery('?ukey=home').'"><img src="'.$logo_url.'" alt="Название на русском" /></a>';
    И получаю проблемы с кодировкой в альте.. Если написать на английском то все норм.. А если на русском то кракозяблики..
    Как решить задачку?
     
  2. mdss

    mdss ♖♘♗♕♔♗♘♖

    Moderator
    Регистр.:
    20 фев 2007
    Сообщения:
    1.130
    Симпатии:
    668
    сохранить файл в кодировке UTF-8
    PS поправить шаблон религия не позволяет?
     
  3. gambiter

    gambiter Писатель

    Регистр.:
    27 авг 2011
    Сообщения:
    5
    Симпатии:
    1
    я правил файл .php , если его сохранить в кодировке отличной от ANSI, то он вообще не будет нормально работать.
    А где править шаблон, что бы изменить тег альт и титле для логотипа?
    Проблема решена, правил все теже строки редактором notepad++, он сам подобрал правильную кодировку к пхп файлу.. паходу (utf-8 без BOM). и все норма работает.