Проблема с установкой Zend

Тема в разделе "Десктопный Linux", создана пользователем bigboss, 11 сен 2011.

Модераторы: Цукер
  1. bigboss

    bigboss

    Регистр.:
    21 авг 2008
    Сообщения:
    161
    Симпатии:
    7
    Приобрел выделенный сервер с ОС Debian 64, но возникла проблема с одним сайтом на DLE просит Zend Optimizer, нашёл статью http://tresnet.ru/archives/476
    устанавливаю всё точно по статье, но толку никакого, кто как решил эту проблему?
     
  2. efs

    efs SEO оптимизатор дискрипторов одностраничных сайтов

    Moderator
    Регистр.:
    20 ноя 2009
    Сообщения:
    825
    Симпатии:
    475
    экстрасенсы в отпуске, но я попробую...
    пых случайно не самый свежий стоит? под него нет еще зенда.
     
  3. bigboss

    bigboss

    Регистр.:
    21 авг 2008
    Сообщения:
    161
    Симпатии:
    7
    пых php5-5.3.3-7
     
  4. efs

    efs SEO оптимизатор дискрипторов одностраничных сайтов

    Moderator
    Регистр.:
    20 ноя 2009
    Сообщения:
    825
    Симпатии:
    475
    или ждать выхода зенд оптимайзера под эту версию php или съезжать на php 5.2 под которую есть зенд.
     
  5. bigboss

    bigboss

    Регистр.:
    21 авг 2008
    Сообщения:
    161
    Симпатии:
    7
    вы 100% уверены что под эту версию нету зенда?
     
  6. UFOS

    UFOS Создатель

    Регистр.:
    19 июн 2008
    Сообщения:
    29
    Симпатии:
    1
    Да ну, а чегож у меня все на дебне с этой версий фурфуркает ;)
     
  7. Crucifer

    Crucifer

    Регистр.:
    6 фев 2007
    Сообщения:
    517
    Симпатии:
    249
    Последняя версия зенд оптимайзера под версию php 5.2

    Зенд сейчас начиная с версии 5.3 начал выпускать Zend Guard Loader. Разработчикам ПО предлагается на него переходить взамен устаревшего оптимайзера.
     
  8. efs

    efs SEO оптимизатор дискрипторов одностраничных сайтов

    Moderator
    Регистр.:
    20 ноя 2009
    Сообщения:
    825
    Симпатии:
    475
    Zend Optimizer у вас на php 5.3 не может работать. его просто нет. а под зенд гвардом у меня некоторые старые скрипты закрытые зендом просто не завелись :( пришлось откатываться
     
  9. UFOS

    UFOS Создатель

    Регистр.:
    19 июн 2008
    Сообщения:
    29
    Симпатии:
    1
    наверное у меня глюки показывает... ;)
    php -v
    PHP Deprecated: Comments starting with '#' are deprecated in /etc/php5/cli/conf.d/ps.ini on line 1 in Unknown on line 0
    PHP 5.3.3-7+squeeze3 with Suhosin-Patch (cli) (built: Jun 28 2011 13:13:26)
    Copyright (c) 1997-2009 The PHP Group
    Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
    with Zend Optimizer+ v4.1, Copyright (c) 1999-2010, by Zend Technologies
    with XCache v1.3.0, Copyright (c) 2005-2009, by mOo
    with Xdebug v2.1.0, Copyright (c) 2002-2010, by Derick Rethans
    with Suhosin v0.9.32.1, Copyright (c) 2007-2010, by SektionEins GmbH

    p.s. только что еще глянул мой хост на CPanel... там стоит FreeBSD + CPanel и вот прям сейчас попробовал пересобрать апач+пых+зенд и собирается вместе с новым пыхом так же без проблем.
     
  10. efs

    efs SEO оптимизатор дискрипторов одностраничных сайтов

    Moderator
    Регистр.:
    20 ноя 2009
    Сообщения:
    825
    Симпатии:
    475
    :nezn: стоит центос 5.4, обновил пыху, зенд оптимайзер не встал, зенд гвард поднялся, но под ним не заработали скрипты.
    завтра еще попробую поднять оптимайзер, раз у вас работает.