Ищу База 1с в сайт

Тема в разделе "Коммерческие", создана пользователем minimalism, 8 авг 2011.

Информация :
Публиковать (для всех) нуленые версии, особенно от modulesgarden КАТЕГОРИЧЕСКИ не стоит. Тема мониторится оным разработчиком, а к нам приходят абузы которые нельзя игнорировать.
Статус темы:
Закрыта.
Модераторы: Amazko, Aste
  1. minimalism

    minimalism Создатель

    Регистр.:
    6 июл 2011
    Сообщения:
    31
    Симпатии:
    1
    Доброго времени суток!
    Помогите найти скрипт или программу для реализаций следующего.
    У нас ведётся база в 1с по ремонту,обслуживанию авто в которой мы вводим номер кузова автомобиля и выводится вся информация по обслуживанию этого авто,что и когда он делал вообщем полная информация.На сайте будет раздел карточка авто где человек вводит свой номер кузова и ему выдаётся вся информация по его автомобилю.
    Подскажите как такое лучше реалезовать есть ли такие скрипты или программы что бы мы экспортировали базу из 1с загружали на сервер где стоит сайт и это всё вот так работало.
    Спасибо!
     
  2. DrakonHaSh

    DrakonHaSh

    Регистр.:
    29 июн 2010
    Сообщения:
    358
    Симпатии:
    122
    * написать на 1с обработку которая экспортирует в txt файл всю необходимую информацию
    * закидывать этот txt на сайт через ftp
    * на сайте считывать всю необходимую инфу из этого txt

    работы по "движку" (не считая веб-интерфейса) на день
     
  3. Fak1r

    Fak1r Постоялец

    Регистр.:
    8 янв 2008
    Сообщения:
    88
    Симпатии:
    18
    Например

    http://habrahabr.ru/blogs/personal/64245/
    Код:
    Создаём обработку 1С, через которую будет производить синхронизация с сервером.
     Тут я поделюсь с вами всего двумя удобными функциями, написанными на 1С.
     В целом алгоритм работы такой: 
     1. Формируется заголовок XML (ниже приведена функция) и DOM документ, в который будет вкладываться в тег все ваши данные, которые нужно отправить на сервер.
     2. Отправляются данные на сервер (ниже приведена функция) и идёт сохранение результатов (если нужно)
    Перем м_ТЗ, м_Дом, м_ДомР, м_HTTPxml; //Переменные с видимостью модуля
     //_________________________________________________________________________________________________
     // Процедура формирует заголовок для XML файла с нашими данными авторизации
     Процедура СформироватьЗаголовокХМЛ()
             м_HTTPxml =  СоздатьОбъект("Microsoft.XMLHTTP");
             м_Дом      = СоздатьОбъект("Msxml2.DOMDocument");
             м_Дом.async = 0;
             м_Дом.loadXML("<root/>");
             Рут    = м_Дом.firstChild;
             Рут.setAttribute("version", СокрЛП(Константа.ВерсияПротокола));
      //Версия протокола (на всякий)
             м_Дом.insertBefore(м_Дом.createProcessingInstruction("xml", "version='1.0' encoding='cp1251'"),Рут);
             // Обязательный блок авторизации
             Юзер        = Рут.appendChild(м_Дом.createNode(1,"user",""));
             Юзер.setAttribute("dt", Константа.ДатаИВремя); 
     //Актуальный таймштамп программы
             Логин       = Юзер.appendChild(м_Дом.createNode(1,"login",""));
             Логин.text  = СокрЛП(Константа.Логин);
             Пароль      = Юзер.appendChild(м_Дом.createNode(1, "password",""));
             Пароль.text = СокрЛП(Константа.Пароль);
             // Данные 
             Данные   = Рут.appendChild(м_Дом.createNode(1, "data",""));        
             Данные.setAttribute("all_data",1);
      // В тег data будут вкладываться в дальнейшем все наши данные
     КонецПроцедуры // СформироватьХМЛ()
     //_________________________________________________________________________________________________
     Процедура ОтправитьДанные()
             // Логгировать результирующий XML можно так:
             //Текст = СоздатьОбъект("Текст"); 
             //Текст.ДобавитьСтроку(м_Дом.xml); 
             //Текст.Записать(КаталогИБ()+"\SYSLOG\dump_out.xml"); 
             //Текст = 0;
             Состояние("Отправляем данные на сервер и ожидаем ответ..");
             // Отправляем данные на сервер
             м_HTTPxml.Open("POST", гл_ХТТП, 0 );
             Попытка
                     м_HTTPxml.Send(м_Дом.xml);
             Исключение
                     Предупреждение("Нет доступа к серверу."+РазделительСтрок+"Пожалуйста, проверьте ваше интернет соединение, или повторите попытку через пару минут");
                     Возврат;
             КонецПопытки;
             ОтветСервера = м_HTTPxml.responseText;
             Состояние("Ответ получен, парсим данные..");
             // Обрабатываем ответ сервера
             м_ДомР = СоздатьОбъект("Msxml2.DOMDocument");
             м_ДомР.async = 0;
             // Логгировать полученный с сервера XML можно вот так:
             Текст = СоздатьОбъект("Текст");
             Текст.ДобавитьСтроку(ОтветСервера);
             Текст.Записать(КаталогИБ()+"\SYSLOG\dump_in.xml");
             Текст = 0;
             // Почему-то через метод loadXML глючит в 1С, и она "втихушку" вываливается, поэтому мы передаём инфу через файл
             м_ДомР.load(КаталогИБ()+"SYSLOG\dump_in.xml");
             Если м_ДомР.parseError.errorCode <> 0 Тогда
                     Сообщить("!!!"+м_ДомР.parseError.reason);
             КонецЕсли;
             Состояние("Записываем данные..");
     КонецПроцедуры // ОтправитьДанные
     Пишем скрипт на php
     Я понимаю, что с XML все умеют работать, поэтому я расскажу тут лишь о самых тонких нюансах.
     Вот наш код. Очень важно использовать кодировку windows-1251, так как библиотека MSDOM не умеет отправлять данные в другой кодировке, и ещё очень важно использовать переменную $HTTP_RAW_POST_DATA.
    $dom = new DOMDocument('1.0','windows-1251');
         if (!empty($HTTP_RAW_POST_DATA)){
             $dom->loadXML($HTTP_RAW_POST_DATA);
         }else{
             die("It's work!"); // Тут можно сделать редирект на руководство по АПИ для вашего сервера или выдать 404 ошибку
         }
     Дальше, я думаю вы сами уже разберётесь, но заканчиваться скрипт может примерно так: 
    header('Content-type: application/xml');
         header('charset: windows-1251');
         die($domR->saveXML());
     
  4. minimalism

    minimalism Создатель

    Регистр.:
    6 июл 2011
    Сообщения:
    31
    Симпатии:
    1
    Это не совсем мне по силам.
     
  5. dandandan

    dandandan

    Регистр.:
    7 авг 2008
    Сообщения:
    990
    Симпатии:
    267
    Тогда только искать программера, который сможет сделать выгрузку из базы 1С и загрузку в базу mysql.

    Конкретно под вас никто скрипт никогда не писал, т.к. наверняка у вас БД доработана. Обычно каждой базе пользователи измачиваются по-своему. И в каждом конкретном случае приходится нужно разбираться со структурой вашей БД.
     
  6. minimalism

    minimalism Создатель

    Регистр.:
    6 июл 2011
    Сообщения:
    31
    Симпатии:
    1
    Ну как сказать.
    Как вариант я нашол web-расширение 1с можно там покопатся.
     
  7. NulleTop

    NulleTop localhost Нарушитель

    Регистр.:
    3 окт 2009
    Сообщения:
    260
    Симпатии:
    37
    Web расширение 1С - это не сайт. Вы можете к нему обратиться через веб, но это будет просто обращение к вашей БД из браузера. Как вы будете учетки пользователям создавать?
     
Статус темы:
Закрыта.