eShop Script

Тема в разделе "eShop", создана пользователем SSJ1989, 7 июл 2011.

  1. gebo

    gebo Создатель

    Регистр.:
    12 дек 2013
    Сообщения:
    20
    Симпатии:
    1
    Насколько я помню с помощью eShop Script можно продавать архивы, текстовые файлы и картинки и недавно появились в сети дополнительные плагины оплаты Payeer, Яндекс деньги и кажется интеркасса.
    И не стоит цепляться к мелочам, создайте архив с Вашими кодами, скриптами и т.д. и продавайте себе на здоровье.
     
  2. webpirat777

    webpirat777

    Регистр.:
    25 апр 2009
    Сообщения:
    209
    Симпатии:
    84
    К каким мелочам? Какой архив? Вы понимаете специфику продажи кодов?
    Выводится 1 товар, у которого много кодов. При продаже 1 экземпляра - продается 1 уникальный код и так далее.
    Соответственно 1 товар создается с множеством кодов. Продается код товара, который всегда разный.
    Продажа 1 кода всем (ну или архива с кодами) не годится, так как первый кто купил его и использует.
     
  3. sdmitrij

    sdmitrij Создатель

    Регистр.:
    22 апр 2015
    Сообщения:
    21
    Симпатии:
    6
    Тоже самое, не рабочая версия. На денвере файл рамером 1,5 мб пытался скачаться 2 минуты, а в конечном итоге вылезли ошибки.
     
  4. gebo

    gebo Создатель

    Регистр.:
    12 дек 2013
    Сообщения:
    20
    Симпатии:
    1
    Уважаемый, зайдите на сайт разработчика и посмотрите требования к хостингу, возможно у Вас из-за этого такое происходит.
    Когда я в последний раз пользовался этим скриптом у меня всё работало без каких либо проблем.
     

    Вложения:

  5. sdmitrij

    sdmitrij Создатель

    Регистр.:
    22 апр 2015
    Сообщения:
    21
    Симпатии:
    6

    Заходил. И во первых у разработчиков я не увидел требования к хостеру. А во вторых, я тестировал в различных режимах на OpenServer, и постоянно выдаются ошибки, что бы я не менял:

    Strict Standards
    : Only variables should be passed by reference in C:\OpenServer\domains\eshop777.ru\app\lib\eshop.php on line 240
    Warning
    : Cannot modify header information - headers already sent by (output started at C:\OpenServer\domains\eshop777.ru\app\lib\eshop.php:240) in C:\OpenServer\domains\eshop777.ru\app\lib\eshop.php on line 281
    Warning
    : Cannot modify header information - headers already sent by (output started at C:\OpenServer\domains\eshop777.ru\app\lib\eshop.php:240) in C:\OpenServer\domains\eshop777.ru\app\lib\eshop.php on line 282
    Warning
    : Cannot modify header information - headers already sent by (output started at C:\OpenServer\domains\eshop777.ru\app\lib\eshop.php:240) in C:\OpenServer\domains\eshop777.ru\app\lib\eshop.php on line 283
    Warning
    : Cannot modify header information - headers already sent by (output started at C:\OpenServer\domains\eshop777.ru\app\lib\eshop.php:240) in C:\OpenServer\domains\eshop777.ru\app\lib\eshop.php on line 299
    Warning
    : Cannot modify header information - headers already sent by (output started at C:\OpenServer\domains\eshop777.ru\app\lib\eshop.php:240) in C:\OpenServer\domains\eshop777.ru\app\lib\eshop.php on line 302
    Warning
    : Cannot modify header information - headers already sent by (output started at C:\OpenServer\domains\eshop777.ru\app\lib\eshop.php:240) in C:\OpenServer\domains\eshop777.ru\app\lib\eshop.php on line 316
    Warning
    : Cannot modify header information - headers already sent by (output started at C:\OpenServer\domains\eshop777.ru\app\lib\eshop.php:240) in C:\OpenServer\domains\eshop777.ru\app\lib\eshop.php on line 317
    %PDF-1.4 %

    И самое интересное. Пример на сайте производите (с нулевой ценой) тоже не работает. Попробуйте сами - http://eshopscript.ru/demo/eshop/?buy=3 У меня ни на мозиле, ни на опере не работает. Может какой особой браузер нужен, я не знаю.

    Так что уважаемый, я не знаю, как у вас этот скипт вообще работал. В топку такой скрипт.

    Мне удалось разобраться, в причинах ошибок в скрипте. Всё банально просто, скрипт устарел, и максимальная версия поддерживаемого пхп это 5.2
     
    Последнее редактирование модератором: 18 ноя 2016
  6. gant

    gant Писатель

    Регистр.:
    8 июн 2014
    Сообщения:
    6
    Симпатии:
    2
    Если на официальном сайт спуститься вниз и посмотреть футер, можно увидеть. что разработчики скрипта давно им не занимаются. Соответственно.. отсюда и вывод:) у меня где то был рабочий. Найду, скину кому надо.
     
  7. Wetal2000

    Wetal2000 Создатель

    Регистр.:
    15 мар 2017
    Сообщения:
    11
    Симпатии:
    3
    Люди помогите, у меня проблема с установкой. В конце когда жмешь кнопку сохранить - вылазит ошибка 404.
     
  8. webpirat777

    webpirat777

    Регистр.:
    25 апр 2009
    Сообщения:
    209
    Симпатии:
    84
    Скрипт устарел и судя по всему не поддерживается. Выберите какой-нибудь другой, актуальный.
     
  9. Wetal2000

    Wetal2000 Создатель

    Регистр.:
    15 мар 2017
    Сообщения:
    11
    Симпатии:
    3
    Не поддерживается чем? Сервером?
     
  10. webpirat777

    webpirat777

    Регистр.:
    25 апр 2009
    Сообщения:
    209
    Симпатии:
    84
    Судя по постановке вопроса, вам бы с основами ознакомиться, чтобы таких вопросов не задавать. Администрация может воспринять как флуд и набор постов, с соответствующими последствиями.

    Что касается конкретно вопроса.
    Движок должен поддерживаться разработчиками, чтобы работать на актуальных, современных версиях серверного ПО. Соответственно, если CMS (движок, скрипт) не поддерживается авторами, то на актуальных серверах работать не будет. Так как серверные операционные системы и ПО постоянно обновляются, находятся уязвимости, устраняются ошибки, и так далее. Поддержка CMS со стороны разработчика по крайней мере включает в себя обновление кода CMS, в соответствии с актуальным ПО, устранение ошибок и уязвимостей. Серьезные разработчики помимо этого постоянно совершенствуют свой продукт и добавляют новые функции.

    Соответственно ответ на вопрос: не поддерживается разработчиком, и соответственно не поддерживается сервером.