Совместимость различных фич на jQuery

Тема в разделе "Веб-дизайн", создана пользователем Di9, 26 май 2011.

Модераторы: zek24
  1. Di9

    Di9 Создатель

    Регистр.:
    19 ноя 2006
    Сообщения:
    33
    Симпатии:
    0
    Собственно во время разработки сайтов все чаще и чаще используются различные модули на jquery, иногда уже в готовом шаблоне что-то есть, иногда собираются отдельные фичи, но очень часто встречаюсь с проблемой совместимости... То есть беру какую-нибудь клевую менюшку и вешаю ее на сайт, прикрепляю js, файл jquery, и все работает..
    Потом думаю что было бы круто сделать какой-нибудь эффект на странице и пытаюсь добавить его, прикручиваю свой js, и jquery (обычно уже другой версии) и все это перестает работать.
    По этому и вопрос - как этого избежать?
     
  2. name-k

    name-k Создатель

    Регистр.:
    18 май 2011
    Сообщения:
    31
    Симпатии:
    16
    Судя по всему, проблема в несовместимости разных версий jQuery, зачем вы вообще подключаете разные версии? Работайте с последней или с той для которой писался нужный вам модуль.
     
  3. Di9

    Di9 Создатель

    Регистр.:
    19 ноя 2006
    Сообщения:
    33
    Симпатии:
    0
    пробую выбирать из двух последнюю, но часто так не работает...
    без сложного анализа кода никакого выхода нет?
     
  4. Mensch

    Mensch

    Регистр.:
    4 сен 2010
    Сообщения:
    182
    Симпатии:
    16
    из того, что видел я. главная проблема чаще всего в css. тоесть кусок кода css нужный одному скрипту, прибивает другой скрипт... такие вот дела.