Проблема с кодировкой - СMS: Joomla

Тема в разделе "Базы данных", создана пользователем tshestel, 31 мар 2011.

Модераторы: latteo
  1. tshestel

    tshestel Постоялец

    Регистр.:
    19 янв 2011
    Сообщения:
    70
    Симпатии:
    3
    Доброго времени суток!
    После переноса сайта с локального сервера в инет полностью слетела русская кодировка.
    Кодировка слетела не только в шаблоне, но и в админке, пробовал ставить чистую джумлу, тоже самое.
    Сайт на Joomla 1.5.7 в базе выставлял utf-8, пробовал дописывать метатеги, их менять, дописывал в htaccess PHP_VALUE default_charset utf-8 и/или AddDefaultCharset utf-8, вообщем не понимаю в чем проблема, может кто сталкивался?

    Хостинг на руцентре,
    Сервер Apache/1.3.37 (Unix)
    PHP/5.2.10 mod_ssl/2.8.28 OpenSSL/0.9.7e-p1
    Версия MySQL-клиента: 5.1.36.
     
  2. frantz1488

    frantz1488

    Регистр.:
    21 мар 2010
    Сообщения:
    162
    Симпатии:
    43
    скорей всего проблема таится в БД, при создании базы нужно выбирать кодировку. У меня была такая же проблема, справился создав новую базу в Phpmyadmin с нужной кодировкой
     
  3. konishoa

    konishoa Постоялец

    Регистр.:
    22 сен 2010
    Сообщения:
    126
    Симпатии:
    36
    Ты когда переносил с помощью блокнота, то она у тебя скопировалась в правильной кодировке, а вставилась в неправильной, а эскьюэль запросы выполнились, потому что и там и тут англ символы не изменились, только русские.
    Совет: пользуйся NOTEPAD++ кодировка всегда должна быть UTF без ВОМ у тебя скорее всего АNSI вылезла.
    Удачи.
     
  4. tshestel

    tshestel Постоялец

    Регистр.:
    19 янв 2011
    Сообщения:
    70
    Симпатии:
    3
    Спасибо.
    Проблема была на хостинге.
    В панели было выставлено cp1251