Помощь Переход с 7.5 - 9.2

Тема в разделе "DLE", создана пользователем kail.2009, 1 мар 2011.

Информация :
Актуальная версия DataLife Engine 11.2
( Final Release v.11.2 | Скачать DataLife Engine | Скачать 11.2 demo )
Нужно ли обновляться | Как обновиться | Изменения в шаблонах
> Нет русских символов <
[Приватная тема DLE (Все подробности в ЛС к модератору раздела)]

Версии 11.1 и ниже - уязвимы!

Локализации | F.A.Q. | Внешний вид
Правила раздела | Правила форума
Обсуждение хайда карается баном!
В каждом сообщении указывайте версию DLE, которого они касаются!
Статус темы:
Закрыта.
Модераторы: killoff
  1. kail.2009

    kail.2009 Постоялец

    Регистр.:
    26 сен 2009
    Сообщения:
    94
    Симпатии:
    10
    Всё-таки решился это сделать :)
    Но не обновлять двиг, а просто поставить новую версию 9.2 и импортировать базу... Шаблон подогнал, работает вроде нормально.
    За основу взял зборку:
    http://cmska.org/constructor.html
    Перенес пару модулей с версии 7.5 и получилось все супер класно :)

    Но вот в чем возникла проблема.. После того как я импортирую базу новостей, категорий и т.д. перестает заходить в полную новость, выдает такую ошибку:
    Код:
    MySQL Error!
    ------------------------
    
    The Error returned was:
    Unknown column 'metatitle' in 'field list'
    
    Error Number:
    1054 
    
    SELECT id, autor, date, short_story, full_story, xfields, title, category, descr, keywords, alt_name, comm_num, allow_comm, allow_rate, fixed, rating, vote_num, news_read, approve, votes, access, flag, editdate, editor, reason, view_edit, tags, metatitle, complaint FROM dle_post where  id = '1767'
    В чем может быть проблема ? :mad:
     
  2. lift

    lift Читатель

    Заблокирован
    Регистр.:
    1 июл 2007
    Сообщения:
    2.226
    Симпатии:
    1.377
    Ну как бы... Если подумать логически... Читает что написанно, тупо и не думая даже:
    Чет я не вижу никаких ссылок на какие то сайты с конструкторами... Интересно почему? Наверное потому, что они не имеют никакого отношения к обновлению движка... Да?
    Открой инструкцию к движку и обнови его. Тогда не будет вываливаться ошибка что у тебя тупо нет нужных полей и таблиц в базе. между 7.5 и 9.2 минимум 3 таблици разници и в _post есть еще как минимум 2 поля.
    И вообще, мелочь конечно, но как бы хороший тон это прочитать инструкцию перед тем как задавать вопросы. Тогда и вопросов вполне возможно не будет вообще.
     
    kail.2009 нравится это.
  3. killoff

    killoff CD тихо, и не DVD меня ;)

    Moderator
    Регистр.:
    13 май 2008
    Сообщения:
    2.101
    Симпатии:
    758
    При обновлении каждой версии идут обновления содержимого базы данных (названия таблиц, добавление новых таблиц/ячеек и т.п.), подробнее смотри в файлах из папки update дистрибутива, там можно при желании вручную все запросы выполнить в пхпмайдмине, но чтобы никому не парить мозги - придумал апдейтер двига который сам все обновит и все сделает, далее останется только подстроить шаблон, установить хаки/моды и прочие изменения который были сделаны в двиге на момент обновления. В документации в общем то все расписано, на офф сайте двига тоже есть инфа!
     
    kail.2009 нравится это.
  4. s2003r

    s2003r Постоялец

    Регистр.:
    13 окт 2006
    Сообщения:
    60
    Симпатии:
    4
    Ответ исчерпывающий , из опыта могу добавить что сталкивался с таким при переходе с 8ой версии на 9тку.
    Заходил в phpmyadmin и выполнял запросы ручками.
     
  5. -=ZorG=-

    -=ZorG=-

    Регистр.:
    18 авг 2010
    Сообщения:
    262
    Симпатии:
    47
    kail.2009
    Выполняем
     
    zapal187 и kail.2009 нравится это.
  6. kail.2009

    kail.2009 Постоялец

    Регистр.:
    26 сен 2009
    Сообщения:
    94
    Симпатии:
    10
    спасибо

    -=ZorG=-, сделал как вы написали, после этого выдало ещё 5 нерабочих таблиц, сделал остальное по вашему примеру и все работает! Спасибо :)

    Теперь столкнулся с ещё одной проблемой..
    Перенос этого хака: http://hipot.ru/forum/topic_77
    Старые картинки открываются как положено, а вот новые открываются с долбаным зумом :(
    Если хто знает в чем проблема напишите пожалуйста
     
Статус темы:
Закрыта.