Can't reconfig DNS server. Make sure DNS service started and right configured.

Тема в разделе "Администрирование серверов", создана пользователем aX0en, 24 фев 2011.

Модераторы: mefish, stooper
  1. aX0en

    aX0en Постоялец

    Регистр.:
    5 авг 2009
    Сообщения:
    108
    Симпатии:
    47
    Не могу добавить домены через панель ISPmanager. Выводит

    Can't reconfig DNS server. Make sure DNS service started and right configured.


    Перезагружаю и вот результаты логов


    /etc/rc.d/init.d/named restart
    Stopping named: . [ OK ]
    Starting named: [ OK ]


    результаты перезагрузки named

    tail /var/log/messages

    Feb 24 07:05:01 named[19577]: couldn't add command channel 127.0.0.1#953: permission denied
    Feb 24 07:05:01 named[19577]: none:0: open: /etc/rndc.key: permission denied
    Feb 24 07:05:01 named[19577]: couldn't add command channel ::1#953: permission denied
    Feb 24 07:05:01 named[19577]: zone 0.in-addr.arpa/IN: loaded serial 0
    Feb 24 07:05:01 named[19577]: zone 1.0.0.127.in-addr.arpa/IN: loaded serial 0
    Feb 24 07:05:01 named[19577]: zone 1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa/IN: loaded serial 0
    Feb 24 07:05:01 named[19577]: zone localhost.localdomain/IN: loaded serial 0
    Feb 24 07:05:01 named[19577]: zone localhost/IN: loaded serial 0
    Feb 24 07:05:01 named[19577]: managed-keys-zone ./IN: loaded serial 152
    Feb 24 07:05:01 named[19577]: running
     
  2. despainer

    despainer

    Регистр.:
    15 фев 2008
    Сообщения:
    615
    Симпатии:
    168
    в конфиге named (/etc/named.conf) закомментрируй строчки которые подключают ненужные файлы (реверсные записи и тд)
    похожее на такое:
    zone "0.0.127.in-addr.arpa" {
    type master;
    file "zone/127.0.0";
    };
    zone "land-5.com" {
    type master;
    file "zone/land-5.com";
    };
    zone "177.6.206.in-addr.arpa" {
    type master;
    file "zone/206.6.177";
    };
    Поставь на файлы /etc/rndc.key права (и проверь владельца)
    в принципе должно запуститься и не создавать проблем!
    Вот пример конфига:


    Код:
    
    [root@master etc]# cat named.conf
    //
    // named.conf
    //
    // Provided by Red Hat bind package to configure the ISC BIND named(8) DNS
    // server as a caching only nameserver (as a localhost DNS resolver only).
    //
    // See /usr/share/doc/bind*/sample/ for example named configuration files.
    //
    
    options {
            listen-on-v6 port 53 { ::1; };
            directory       "/var/named";
            dump-file       "/var/named/data/cache_dump.db";
            statistics-file "/var/named/data/named_stats.txt";
            memstatistics-file "/var/named/data/named_mem_stats.txt";
            recursion yes;
    
            dnssec-enable yes;
            dnssec-validation yes;
            dnssec-lookaside auto;
    
            /* Path to ISC DLV key */
            bindkeys-file "/etc/named.iscdlv.key";
            
    
    logging {
            channel default_debug {
                    file "data/named.run";
                    severity dynamic;
            };
    };
    
    //zone "." IN {
    //        type hint;
    //        file "named.ca";
    //};
    
    //include "/etc/named.rfc1912.zones";
    
    
    [root@master etc]#
    
    

    ссылка на HOWTO



    http://www.linux.org.ru/books/HOWTO/DNS-HOWTO-5.html
     
    aX0en нравится это.
  3. aX0en

    aX0en Постоялец

    Регистр.:
    5 авг 2009
    Сообщения:
    108
    Симпатии:
    47
    Решил так.

    This bug can be fixed by:
    1) Adding a line that says
    include "/etc/bind/rndc.key";
    to /etc/bind/named.conf
    and then
    2) Making /etc/bind/rndc.key be owner root:bind mode 640