проблема с .htaccess

Тема в разделе "Коммерческие", создана пользователем backzzz, 15 фев 2011.

Информация :
Публиковать (для всех) нуленые версии, особенно от modulesgarden КАТЕГОРИЧЕСКИ не стоит. Тема мониторится оным разработчиком, а к нам приходят абузы которые нельзя игнорировать.
Статус темы:
Закрыта.
Модераторы: Amazko, Aste
  1. backzzz

    backzzz Создатель

    Регистр.:
    17 июл 2010
    Сообщения:
    25
    Симпатии:
    0
    Установил скрипт все работает нормально но при создании поддомена
    имя.имя.ру выдает Internal Server Error причина как я понял в .htaccess если в .htaccess удалить строчку RewriteRule .* index.php
    то поддомен работает но на домене 2ого уровня работает только главная страница,а все категории Ошибка 404.
    Так же при открытие странице типа Перейти по ссылке
    автоматом переправляет на главную.
    Как отредактировать .htaccess чтобы все работало.
     
  2. RussКиЙ

    RussКиЙ

    Регистр.:
    23 сен 2009
    Сообщения:
    506
    Симпатии:
    59
    Полный файл .htaccess в студию, тоесть весь код из него.
     
  3. backzzz

    backzzz Создатель

    Регистр.:
    17 июл 2010
    Сообщения:
    25
    Симпатии:
    0
    RewriteEngine On
    RewriteRule robots\.txt robots.txt [L,NC]
    RewriteRule .* index.php


    # unicode support
    AddDefaultCharset utf-8
    <IfModule mod_charset.c>
    CharsetDIsable on
    CharsetRecodeMultipartForms Off
    </IfModule>

    php_value mbstring.func_overload 7
    php_value default_charset UTF-8
    php_value mbstring.language Russian

    php_value mbstring.internal_encoding UTF-8

    php_flag mbstring.encoding_translation on

    php_value mbstring.http_input "UTF-8,KOI8-R,CP1251"

    php_value mbstring.http_output UTF-8
    php_value mbstring.detect_order "UTF-8,KOI8-R,CP1251"
    # end

    php_flag magic_quotes_gpc off
    php_value session.use_trans_sid 0
    это из скрипта yanaidu.ru
     
  4. PROSx

    PROSx Создатель

    Регистр.:
    1 май 2010
    Сообщения:
    18
    Симпатии:
    0


    пробовал удалить по частям? оставь только нужное да и все. а оставльное пропиши в .ini . может это из за хостинга?
    Потому что бывает когда ты очень часто удаляешь и снова добавляешь поддомен оно ошибки кидает, жди по крайней мере 6-12ч. потом уже смотри. а если что то попробуй отключит ЧПУ и удалять все по частям и там уже смотри что получиться.


    А если по скрипту, то по моему скрипт этот корявый...
     
Статус темы:
Закрыта.