Помощь Проблема со вставкой флэша

Тема в разделе "DLE", создана пользователем Forzel, 14 фев 2011.

Информация :
Актуальная версия DataLife Engine 12.0
( Final Release v.12.0 | Скачать DataLife Engine | Скачать 12.0 demo )
Нужно ли обновляться | Как обновиться | Изменения в шаблонах
> Нет русских символов <
[Приватная тема DLE (Все подробности в ЛС к модератору раздела)]

Версии 11.3 и ниже - уязвимы!

Локализации | F.A.Q. | Внешний вид
Правила раздела | Правила форума
Обсуждение хайда карается баном!
В каждом сообщении указывайте версию DLE, которого они касаются!
Статус темы:
Закрыта.
Модераторы: killoff
  1. Forzel

    Forzel Создатель

    Регистр.:
    19 июл 2010
    Сообщения:
    46
    Симпатии:
    2
    Всем доброго времени суток!

    Делаю на сайте раздел электронного журнала. Заходишь в такую новость - и листаешь странички во флэше. Красиво и интересно.

    Генерирую такие журнальчики FlippingBook Publisher, нуленным. В итоге он выдает основной флэш файл и пару папок с подгружаемыми в процессе картинками и эффектами переворачивания страниц. Плюс в том, что нет необходимости грузить сначала весь тяжелый журнал, чтобы его прочесть. Загрузка идет постранично.

    Так вот, столкнулся с проблемой отображения. В качестве движка юзаю нуль 9.0. Простой HTML-код, выдаваемый прогой, двиг не жрет ни в какую, вещает об ошибке. Покопался на сайте разработчика FBP - там про лицензию на домены пишут и прочую хрень. Ну да ладно. Решил вручную ставить. Как исполняемый флэш подгружаю в редакторе базовый флэш-файлик - он отвечает за оболочку журнала - все работает. Но дальше ни в какую! Никак не могу понять, как к нему две исполняемые папки привязать...

    Может у кого схожие проблемы с отображением сложносоставных флэшей на сайте?
     
  2. gruz222

    gruz222 Постоялец

    Регистр.:
    8 авг 2008
    Сообщения:
    62
    Симпатии:
    6
    там еще должен идти к нему .xml файл с настройками
     
  3. Forzel

    Forzel Создатель

    Регистр.:
    19 июл 2010
    Сообщения:
    46
    Симпатии:
    2
    .xml нашел, но никакие пути не помогают. Пробовал даже в корень кидать, учитывая, что CMS работают от корня.
    Может, есть какой-то глюк именно у DLE с отображением подгружаемых через .xml флэшек?
     
  4. gruz222

    gruz222 Постоялец

    Регистр.:
    8 авг 2008
    Сообщения:
    62
    Симпатии:
    6
    Во-первых посмотри в правильном ли месте лежит .xml

    ибо во флешке путь к нему тоже зафиксирован, и если в оригинале xml лежал в папке "папка" , то у тебя на сайте должно быть также,

    +

    посмотри какие еще файлы использовала рабочая флешка,
    посмотри что написано в xml
    не используй относительные пути к файлам и папкам
     
Статус темы:
Закрыта.