Проблема с apt-get

Тема в разделе "Десктопный Linux", создана пользователем Maza, 7 фев 2011.

Модераторы: Цукер
  1. Maza

    Maza

    Регистр.:
    3 июл 2007
    Сообщения:
    255
    Симпатии:
    118
    Не давно после удаление iceweseal из системы и установки firefox, c apt-get и aptitude стали происходить чудеса. При установке программы через них вываливается предложение снести всё окружение Gnome, думал проблема в репозиториях, и ошибках в пакетах, оказалось, что нет. Может было у кого-нибудь подобное.
    Вот такую вещь выдаёт.

    HTML:
    
    $ sudo apt-get install juffed
    Чтение списков пакетов... Готово
    Построение дерева зависимостей       
    Чтение информации о состоянии... Готово
    Уже установлена самая новая версия juffed.
    Следующие пакеты устанавливались автоматически и больше не требуются:
      libmono-addins-gui0.2-cil sg3-utils libopenal1 bluez-gnome libsdl1.2debian
      libfreebob0 libsdl1.2debian-alsa libepc-ui-1.0-1 planner tomboy espeak ekiga
      libgsf-gnome-1-114 libmono2.0-cil libartsc0 libmtp7 libmono-security1.0-cil
      gcalctool sharutils libmono-data-tds2.0-cil libpth20 gnuchess-book
      gnome-nettool libgoffice-0-common libmono-i18n2.0-cil gnome-games-extra-data
      libepc-1.0-1 libgtk-vnc-1.0-0 libgksu1.2-0 python-notify
      libgail-gnome-module libmono0 libglade2.0-cil libmono-system-data2.0-cil
      libportaudio2 gstreamer0.10-plugins-ugly pkg-config libglib2.0-cil
      abiword-plugin-goffice obex-data-server libmono-sharpzip0.84-cil ncompress
      libgnome-mag2 libgda3-common python-gnome2-extras gucharmap zenity
      libgksuui1.0-1 gnome-games cheese gdebi evolution-exchange libgconf2.0-cil
      libots0 libspectre1 gnome-network-admin libbeecrypt6 libsvga1
      libmono-system-web1.0-cil gnome-power-manager unzip gnome-cards-data
      totem-plugins lzop cli-common libglew1.5 ggzcore-bin gnome-mag
      gnome-screensaver rhythmbox libjack0 libmono-corlib1.0-cil python-gdata
      kdelibs-data gedit kdebase-data liblircclient0 python-gtksourceview2
      gtk2-engines-pixbuf gnome-office system-config-printer
      libaiksaurusgtk-1.2-0c2a abiword-common abiword abiword-plugin-mathview
      latex-xft-fonts libart2.0-cil libpt-1.10.10-plugins-alsa
      libaiksaurus-1.2-0c2a gnome-themes seahorse libggzmod4 liblualib50
      libsqlite0 libsgutils1 gdebi-core totem-common vinagre gnumeric-common
      libpt-1.10.10 libndesk-dbus1.0-cil libgpod3 mono-common libgalago3
      festlex-cmu dasher guile-1.8-libs libloudmouth1-0 libmysqlclient15off
      link-grammar-dictionaries-en libgnome2.0-cil python-gtkmozembed
      python-gtkhtml2 p7zip gedit-common gnome-themes-extras libalut0
      libgoffice-0-6-common libdmx1 libbrlapi0.5 finger bluez-utils libatspi1.0-0
      libxevie1 libmono-addins0.2-cil gdm-themes gnome-orca libmusicbrainz4c2a
      fast-user-switch-applet abiword-help arj python-pyatspi libakode2
      gnome-volume-manager bluez-audio gtk2-engines libmono-system1.0-cil
      libgtksourceview2.0-common libkpathsea4 librpm4.4 libmono-security2.0-cil
      libt1-5 eog gdm libgtksourceview2.0-0 libaiksaurus-1.2-data libwv-1.2-3
      python-4suite-doc libgif4 gnome-backgrounds dasher-data python-eggtrayicon
      gok python-brlapi libgdome2-0 python-sexy gnome-spell espeak-data
      libgtk2.0-cil mono-gac libggz2 abiword-plugin-grammar festlex-poslex at-spi
      libmono1.0-cil vino mousetweaks libmono-data-tds1.0-cil
      libmono-sqlite2.0-cil libmono-i18n1.0-cil mono-jit libsamplerate0 evince
      gnome-games-data festvox-kallpc16k liblzo2-2 gnome-app-install
      libmono-system-data1.0-cil libmono-system-web2.0-cil libespeak1
      libgoffice-0-4 libgoffice-0-6 libdvdnav4 libmono-sharpzip2.84-cil rpm
      libopal-2.2 totem-gstreamer libmono-corlib2.0-cil libgpod-common libdvdread3
      libgnomevfs2-bin libgnome-speech7 mono-runtime libgmime-2.0-2a
      xserver-xephyr libgdome2-cpp-smart0c2a libsidplay1 zip python-gdbm
      gnome-core dmz-cursor-theme python-4suite-xml libcolorblind0 libgda3-bin
      libmad0 gnumeric libgda3-3 festival svgalibg1 rss-glx
      libpt-1.10.10-plugins-v4l libgpgme11 libndesk-dbus-glib1.0-cil libid3tag0
      libggzcore9 libgmyth0 liblink-grammar4 gnome-system-tools libgtkmathview0c2a
      libgmime2.2-cil gnome-accessibility liblua50 gnuchess gstreamer0.10-gnomevfs
      totem gnome-accessibility-themes binfmt-support unace libgnome-vfs2.0-cil
      libavahi-ui0 transmission-common libestools1.2 libmono-cairo1.0-cil
      gstreamer0.10-tools totem-mozilla libmono-system2.0-cil libgdl-1-0
      libmpeg2-4 file-roller libgdiplus serpentine libopenobex1 libspeexdsp1
      transmission-gtk sound-juicer libgdl-1-common gnome-vfs-obexftp liba52-0.7.4
    Для их удаления используйте 'apt-get autoremove'.
    обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
    
     
  2. Maza

    Maza

    Регистр.:
    3 июл 2007
    Сообщения:
    255
    Симпатии:
    118
    Разобрался в чём была проблема, при удаление swfdec пакета он за собой Гнома потащил.
    Решается проблема командой
     
    coguar нравится это.
  3. Bulatti

    Bulatti Создатель

    Регистр.:
    17 авг 2010
    Сообщения:
    23
    Симпатии:
    3
    Кстати частая проблема в убунте) Надо контролировать процесс удаления...
    а то частенько какая-нибудь прога за собой тянет еще что нибудь... падала система не раз...(
     
  4. 94Hours

    94Hours Постоялец

    Регистр.:
    23 ноя 2011
    Сообщения:
    57
    Симпатии:
    8
    А че?)))) Главное не уйти в ребут))))
    Копируешь вес процесс удаления в блокнотик и сидишь переписываешь команды удалить, на установить)))
    По своей невнимательности, пришлось такое делать дважды))))
    Ну хоть не на свое машине))))
     
  5. citadeldimon

    citadeldimon Создатель

    Регистр.:
    27 авг 2008
    Сообщения:
    43
    Симпатии:
    2
    Есть такая фигня с гномом, очень тяжело выпилить предустановленные с ним проги, уж проще забить на них.
     
  6. Maksushkin

    Maksushkin Создатель

    Регистр.:
    10 янв 2012
    Сообщения:
    32
    Симпатии:
    3
    Та и с кедами такая проблемма часто бывала. Я одно время сидел на кедых... постоянные проблемы...
    Да и вообще кеды это сплошная проблемма как и виндовс)))
    Два года на гноме сижу))) перед НГ поставил вообще гном3.. пока нравится...