apt-get/aptitude в debian

Тема в разделе "Администрирование серверов", создана пользователем DeViL[ua], 20 янв 2011.

Модераторы: mefish, stooper
  1. DeViL[ua]

    DeViL[ua] Постоялец

    Регистр.:
    1 авг 2009
    Сообщения:
    95
    Симпатии:
    18
    Всем привет, у меня при работе с apt-get возникают ошибки..
    Не знаю как исправить. Вроде что-то накосячил (((
    Вот пример ошибки:
    apt-get/aptitude в debian
     
  2. ShaDeRzz

    ShaDeRzz

    Регистр.:
    16 окт 2007
    Сообщения:
    176
    Симпатии:
    65
    Выполните

    Код:
    apt-get autoremove
    Это должно удалить неудалённые зависимости от уже удалённых пакетов.

    Ну и выполните как вас просят:

    Код:
    apt-get -f install

    Ещё как вариант проверьте ваши репозитории. Возможно пакеты ставятся с разных репозиториев и поэтому начинают тянуть несовместимые или устаревшие данные.
     
  3. DeViL[ua]

    DeViL[ua] Постоялец

    Регистр.:
    1 авг 2009
    Сообщения:
    95
    Симпатии:
    18
    Выполнил. Вот что получилось!


     
  4. fire002

    fire002 Создатель

    Регистр.:
    4 апр 2009
    Сообщения:
    47
    Симпатии:
    11
    rm -f /var/cache/apt/archives/libc6_2.7-18lenny7_amd64.deb
    dpkg -configure -a
     
  5. DeViL[ua]

    DeViL[ua] Постоялец

    Регистр.:
    1 авг 2009
    Сообщения:
    95
    Симпатии:
    18
    :~# dpkg -configure -a
    dpkg: unknown option -o

    Type dpkg --help for help about installing and deinstalling packages [*];
    Use `dselect' or `aptitude' for user-friendly package management;
    Type dpkg -Dhelp for a list of dpkg debug flag values;
    Type dpkg --force-help for a list of forcing options;
    Type dpkg-deb --help for help about manipulating *.deb files;
    Type dpkg --license for copyright license and lack of warranty (GNU GPL) [*].

    Options marked [*] produce a lot of output - pipe it through `less' or `more' !
     
  6. fire002

    fire002 Создатель

    Регистр.:
    4 апр 2009
    Сообщения:
    47
    Симпатии:
    11
    dpkg --configure -a
     
  7. DeViL[ua]

    DeViL[ua] Постоялец

    Регистр.:
    1 авг 2009
    Сообщения:
    95
    Симпатии:
    18
    Код:
    cyberAREA:~# rm -f /var/cache/apt/archives/libc6_2.7-18lenny7_amd64.deb
    cyberAREA:~# dpkg --configure -a
    cyberAREA:~# apt-get upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    You might want to run `apt-get -f install' to correct these.
    The following packages have unmet dependencies:
      adduser: Depends: perl-base (>= 5.6.0) but it is not installed
      debconf: PreDepends: perl-base (>= 5.6.1-4) but it is not installed
      dictionaries-common: Depends: perl-base (>= 5.6.0-16) but it is not installed
      libc6-dev: Depends: libc6 (= 2.7-18lenny7) but 2.7-18lenny6 is installed
      libc6-i386: Depends: libc6 (= 2.7-18lenny7) but 2.7-18lenny6 is installed
      liblocale-gettext-perl: PreDepends: perl-base (>= 5.10.0-9) but it is not installed
                              PreDepends: perlapi-5.10.0
      libtext-charwidth-perl: Depends: perl-base (>= 5.10.0-9) but it is not installed
                              Depends: perlapi-5.10.0
      libtext-iconv-perl: Depends: perl-base (>= 5.10.0-9) but it is not installed
                          Depends: perlapi-5.10.0
      perl: Depends: perl-base (= 5.10.0-19lenny2) but it is not installed
    E: Unmet dependencies. Try using -f.
    cyberAREA:~# apt-get -f install
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Correcting dependencies... Done
    The following packages were automatically installed and are no longer required:
      libfreetype6 libexpat1 libxpm4 libjpeg62
    Use 'apt-get autoremove' to remove them.
    The following extra packages will be installed:
      libc6 perl perl-base perl-modules
    Suggested packages:
      glibc-doc perl-doc libterm-readline-gnu-perl libterm-readline-perl-perl
    The following NEW packages will be installed:
      perl-base
    The following packages will be upgraded:
      libc6 perl perl-modules
    3 upgraded, 1 newly installed, 0 to remove and 8 not upgraded.
    3 not fully installed or removed.
    Need to get 4812kB/14.3MB of archives.
    After this operation, 5308kB of additional disk space will be used.
    
     
  8. fire002

    fire002 Создатель

    Регистр.:
    4 апр 2009
    Сообщения:
    47
    Симпатии:
    11
    У меня такое впечатление, что там репозитарии левый, с разными версиями одного софта.
    aptitude update
    пробовал?
     
  9. DeViL[ua]

    DeViL[ua] Постоялец

    Регистр.:
    1 авг 2009
    Сообщения:
    95
    Симпатии:
    18
    sources.list
    Код:
    # 
    # deb cdrom:[Debian GNU/Linux 5.0.6 _Lenny_ - Official amd64 NETINST Binary-1 20100905-11:18]/ lenny main
    
    #deb cdrom:[Debian GNU/Linux 5.0.6 _Lenny_ - Official amd64 NETINST Binary-1 20100905-11:18]/ lenny main
    
    deb http://ftp.ua.debian.org/debian/ lenny main
    deb-src http://ftp.ua.debian.org/debian/ lenny main
    
    deb http://security.debian.org/ lenny/updates main
    deb-src http://security.debian.org/ lenny/updates main
    
    deb http://volatile.debian.org/debian-volatile lenny/volatile main
    deb-src http://volatile.debian.org/debian-volatile lenny/volatile main
    
    Код:
    cyberAREA:~# aptitude update
    Writing extended state information... Done
    Hit http://ftp.ua.debian.org lenny Release.gpg
    Ign http://ftp.ua.debian.org lenny/main Translation-en_US
    Hit http://ftp.ua.debian.org lenny Release
    Ign http://ftp.ua.debian.org lenny/main Packages/DiffIndex
    Ign http://ftp.ua.debian.org lenny/main Sources/DiffIndex
    Hit http://ftp.ua.debian.org lenny/main Packages
    Hit http://ftp.ua.debian.org lenny/main Sources
    Hit http://security.debian.org lenny/updates Release.gpg
    Ign http://security.debian.org lenny/updates/main Translation-en_US
    Hit http://security.debian.org lenny/updates Release
    Ign http://security.debian.org lenny/updates/main Packages/DiffIndex
    Ign http://security.debian.org lenny/updates/main Sources/DiffIndex
    Hit http://security.debian.org lenny/updates/main Packages
    Hit http://security.debian.org lenny/updates/main Sources
    Hit http://volatile.debian.org lenny/volatile Release.gpg
    Ign http://volatile.debian.org lenny/volatile/main Translation-en_US
    Hit http://volatile.debian.org lenny/volatile Release
    Ign http://volatile.debian.org lenny/volatile/main Packages/DiffIndex
    Ign http://volatile.debian.org lenny/volatile/main Sources/DiffIndex
    Hit http://volatile.debian.org lenny/volatile/main Packages
    Hit http://volatile.debian.org lenny/volatile/main Sources
    Reading package lists... Done
    
    cyberAREA:~# aptitude upgrade
    W: The "upgrade" command is deprecated; use "safe-upgrade" instead.
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Reading extended state information
    Initializing package states... Done
    Reading task descriptions... Done
    Resolving dependencies...
    The following NEW packages will be installed:
      perl-base{a}
    The following packages will be REMOVED:
      libexpat1{u} libfreetype6{u} libjpeg62{u} libxpm4{u}
    The following packages will be upgraded:
      apache2-doc base-files dpkg libc6 libssl-dev libssl0.9.8 libxml2 locales
      man-db perl perl-modules
    The following partially installed packages will be configured:
      libc6-dev libc6-i386
    The following packages are RECOMMENDED but will NOT be installed:
      xml-core
    11 packages upgraded, 1 newly installed, 4 to remove and 0 not upgraded.
    Need to get 19.0MB/28.4MB of archives. After unpacking 3305kB will be used.
    Do you want to continue? [Y/n/?] y
    Writing extended state information... Done
    Get:1 http://ftp.ua.debian.org lenny/main libc6 2.7-18lenny7 [4812kB]
    Get:2 http://ftp.ua.debian.org lenny/main base-files 5lenny9 [64.5kB]
    Get:3 http://ftp.ua.debian.org lenny/main dpkg 1.14.31 [2402kB]
    Get:4 http://ftp.ua.debian.org lenny/main libssl-dev 0.9.8g-15+lenny11 [2249kB]
    Get:5 http://ftp.ua.debian.org lenny/main libssl0.9.8 0.9.8g-15+lenny11 [978kB]
    Get:6 http://ftp.ua.debian.org lenny/main man-db 2.5.2-5 [1098kB]
    Get:7 http://ftp.ua.debian.org lenny/main libxml2 2.6.32.dfsg-5+lenny3 [860kB]
    Get:8 http://ftp.ua.debian.org lenny/main locales 2.7-18lenny7 [4432kB]
    Get:9 http://ftp.ua.debian.org lenny/main apache2-doc 2.2.9-10+lenny9 [2062kB]
    Fetched 19.0MB in 2s (7450kB/s)
    debconf: Perl may be unconfigured (Can't locate strict.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.10.0 /usr/local/share/perl/5.10.0 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl .) at (eval 1) line 2.
    BEGIN failed--compilation aborted at (eval 1) line 2.
    ) -- aborting
    (Reading database ...
    dpkg: serious warning: files list file for package `libc6-dev' missing, assuming package has no files currently installed.
    
    dpkg: serious warning: files list file for package `libc6-i386' missing, assuming package has no files currently installed.
    
    dpkg: serious warning: files list file for package `php5-cli' missing, assuming package has no files currently installed.
    
    dpkg: serious warning: files list file for package `libc6' missing, assuming package has no files currently installed.
    37444 files and directories currently installed.)
    Preparing to replace libc6 2.7-18lenny6 (using .../libc6_2.7-18lenny7_amd64.deb) ...
    Can't locate strict.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.10.0 /usr/local/share/perl/5.10.0 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl .) at /usr/share/debconf/frontend line 5.
    BEGIN failed--compilation aborted at /usr/share/debconf/frontend line 5.
    dpkg: error processing /var/cache/apt/archives/libc6_2.7-18lenny7_amd64.deb (--unpack):
     subprocess pre-installation script returned error exit status 2
    Errors were encountered while processing:
     /var/cache/apt/archives/libc6_2.7-18lenny7_amd64.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    A package failed to install.  Trying to recover:
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Reading extended state information
    Initializing package states... Done
    Writing extended state information... Done
    Reading task descriptions... Done
    
    
     
  10. budulay

    budulay

    Регистр.:
    8 апр 2006
    Сообщения:
    283
    Симпатии:
    87