Помогите настроить Bind dns 9.6

Тема в разделе "Администрирование серверов", создана пользователем mulekula, 15 янв 2011.

Модераторы: mefish, stooper
  1. mulekula

    mulekula Постоялец

    Регистр.:
    6 дек 2008
    Сообщения:
    91
    Симпатии:
    2
    Помогите прикрепить домен к сайту!
    Может есть какие мануалы по этой процедуре...
     
  2. masterlan

    masterlan

    Регистр.:
    14 окт 2009
    Сообщения:
    530
    Симпатии:
    51
    У вас должно быть 2 bind-a на разных ip.
    В конец файла named.conf (На master DNS:(
    Следовательно в /etc/namedb/master/sait.ru
    В конец файла named.conf (На master DNS:(
    };
    Следовательно в /etc/namedb/slave/sait.ru
    192.168.2.1 IP DNS2 (Slave)
    192.168.1.1 IP DNS1 (Master)
     
    mulekula нравится это.
  3. vlad77

    vlad77 Создатель

    Регистр.:
    17 апр 2008
    Сообщения:
    16
    Симпатии:
    2
    В панели управления доменом (или пишешь письмо регистратору, если он такую панель не предоставляет) прописываешь ns-сервера хостинга, на котором находятся файлы сайта. NS-сервера спрашиваешь у хостера
     
  4. mulekula

    mulekula Постоялец

    Регистр.:
    6 дек 2008
    Сообщения:
    91
    Симпатии:
    2
    masterlan,можешь помочь! мне не получается вообще.
    моя ася 414406850
     
  5. masterlan

    masterlan

    Регистр.:
    14 окт 2009
    Сообщения:
    530
    Симпатии:
    51
    Панель управления типа ISPmanager есть?
    Если нет, то вот для примера
    best-server.at.ua/publ/4-1-0-11
     
  6. mulekula

    mulekula Постоялец

    Регистр.:
    6 дек 2008
    Сообщения:
    91
    Симпатии:
    2
    У вас должно быть 2 bind-a на разных ip.
    это могут быть
    Наши NS-сервера:
    ns1.infiumhost.com 91.218.36.1 (Украина)
    ns2.infiumhost.com 193.106.28.214 (Украина)
    регистратора?
    Или мне нужно покупать два выделенных айпи?
     
  7. masterlan

    masterlan

    Регистр.:
    14 окт 2009
    Сообщения:
    530
    Симпатии:
    51
    Вы можете пользоваться NS инфиумхоста.
    Если хотите все свое, то покупайте еще vds или просто ip.
    Только нужно ли это вам?
     
  8. mulekula

    mulekula Постоялец

    Регистр.:
    6 дек 2008
    Сообщения:
    91
    Симпатии:
    2
    хмм тогда лучше будет использовать инфиума)
    Мастер 91.218.36.1
    Слейв 193.106.28.214

    Добавлено через 52 минуты
    При создании и запуске зоны получаю ошибку!
    Что это значит??
    NDC command failed : rndc: connect failed: 127.0.0.1#953: connection refused
     
  9. masterlan

    masterlan

    Регистр.:
    14 окт 2009
    Сообщения:
    530
    Симпатии:
    51
    Вам dns предоставляет infiumhost ?
    Напишите суппорту, они обычно помогают.
     
  10. mulekula

    mulekula Постоялец

    Регистр.:
    6 дек 2008
    Сообщения:
    91
    Симпатии:
    2
    проблема решена!
    Теперь возникла другая ...
    При установке любого модуля выбивает ошибка! что делать!
    Вот полный ЛОГ установки

    PHP:
    apt-get ---force-yes -f install phpmyadmin
    Reading package lists
    ...
    Building dependency tree...
    Reading state information...
    You might want to run `apt-get -f install' to correct these:
    The following packages have unmet dependencies:
      phpmyadmin: Depends: libapache2-mod-php5 but it is not going to be installed or
                           libapache-mod-php5 but it is not installable or
                           php5-cgi but it is not going to be installed or
                           php5 but it is not going to be installed or
                           libapache2-mod-php4 but it is not installable or
                           libapache-mod-php4 but it is not installable or
                           php4 but it is not installable or
                           php4-cgi but it is not installable
                  Depends: php5-mysql but it is not going to be installed or
                           php5-mysqli but it is not installable or
                           php4-mysql but it is not installable
                  Depends: php5-mcrypt but it is not going to be installed or
                           php4-mcrypt but it is not installable
                  Recommends: php5-gd but it is not going to be installed or
                              php4-gd but it is not installable
      webmin: Depends: apt-show-versions but it is not going to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).