SocialEngine 3 - Не отправляет E-Mail

Тема в разделе "Social Engine", создана пользователем vave, 10 янв 2011.

  1. vave

    vave

    Регистр.:
    23 июн 2007
    Сообщения:
    364
    Симпатии:
    14
    Здравствуйте,
    После работы с БД SocialEngine 3 перестал отправлять E-Mail пользователям, уведомления, и даже забытый пароль не высылает, подскажите какую таблицу в БВ нужно чинить?
     
  2. DMS

    DMS Злодей

    Moderator
    • Супермодератор
    Регистр.:
    22 окт 2010
    Сообщения:
    631
    Симпатии:
    348
    проверь параметры в se_settings и se_systememails также можно и se_languagevars посмотреть текст кажится от туда тянет
     
    vave нравится это.
  3. globitex

    globitex Постоялец

    Регистр.:
    11 дек 2009
    Сообщения:
    133
    Симпатии:
    2
    C паролем бывает глюк, особенно с восстановлением: присылает письмо, имя написано, а вместо пароля пусто, это тоже актуально к данной теме, поэтому может тоже кто даст ответ?

    А по сути надо смотреть настройки emailer или sendmail, смотря как реализована отправка.

    Забыл написать решение, особо глюк не нашли, но помогла переустановка движка. Может у кого есть решение без переустановки?
     
  4. vave

    vave

    Регистр.:
    23 июн 2007
    Сообщения:
    364
    Симпатии:
    14
    Проблема была именно в se_settings.
    кнопочку спасибо нажал, спасибо!:)
     
  5. vave

    vave

    Регистр.:
    23 июн 2007
    Сообщения:
    364
    Симпатии:
    14
    Только теперь общественность не может просматривать сайт, где изменить настройку что бы незарегистрированные пользователи могли просматривать сайт?
     
  6. DMS

    DMS Злодей

    Moderator
    • Супермодератор
    Регистр.:
    22 окт 2010
    Сообщения:
    631
    Симпатии:
    348
    В админке проверь стоит разрешение или нет? На 3 ветке щас не вспомню где, на 2.8 было Главные настройки-Общие настройки-Профили(Да, общественность может просматривать профили, кроме закрытых) возможно и в 3 там же.
     
  7. vave

    vave

    Регистр.:
    23 июн 2007
    Сообщения:
    364
    Симпатии:
    14
    там всё в порядке.. :confused:

    Добавлено через 5 минут
    это случилось после обновления базы se_settings

    Добавлено через 33 минуты
    Из таблицы пропали:

    `setting_permission_profile` tinyint(1) NOT NULL DEFAULT '1',
    `setting_permission_invite` tinyint(1) NOT NULL DEFAULT '1',
    `setting_permission_search` tinyint(1) NOT NULL DEFAULT '1',
    `setting_permission_portal` tinyint(1) NOT NULL DEFAULT '1',
    `setting_permission_album` int(1) NOT NULL DEFAULT '1',
    `setting_permission_blog` tinyint(4) NOT NULL DEFAULT '1',
    `setting_permission_classified` int(1) NOT NULL DEFAULT '1',
    `setting_permission_event` tinyint(4) NOT NULL DEFAULT '1',
    `setting_permission_group` int(1) NOT NULL DEFAULT '1',
    `setting_permission_poll` tinyint(3) unsigned DEFAULT '1',
    `setting_poll_html` text COLLATE utf8_unicode_ci,
    `setting_permission_kiss` int(1) NOT NULL DEFAULT '0',
    `setting_permission_commented` int(1) NOT NULL DEFAULT '1',
    `setting_commented_license` varchar(255) COLLATE utf8_unicode_ci NOT NULL DEFAULT '',
    `setting_permission_article` int(1) NOT NULL DEFAULT '0',
    `setting_email_articlecomment_subject` varchar(200) COLLATE utf8_unicode_ci NOT NULL DEFAULT '',
    `setting_email_articlecomment_message` text COLLATE utf8_unicode_ci,
    `setting_email_articlemediacomment_subject` varchar(200) COLLATE utf8_unicode_ci NOT NULL DEFAULT '',
    `setting_email_articlemediacomment_message` text COLLATE utf8_unicode_ci,
    `setting_permission_game` tinyint(1) unsigned NOT NULL DEFAULT '1',


    как их лучше всего вернуть?
     
  8. DMS

    DMS Злодей

    Moderator
    • Супермодератор
    Регистр.:
    22 окт 2010
    Сообщения:
    631
    Симпатии:
    348
    сделай бекап таблицы se_settings, затем удали ее в базе после в бекапе добавь не достающие поля что бы стало примерно так, и добавь через sql запрос в базу