Coppermine Photo Gallery кодировка и плагин MiniCMS

Тема в разделе "Коммерческие", создана пользователем bummm, 1 дек 2010.

Информация :
Публиковать (для всех) нуленые версии, особенно от modulesgarden КАТЕГОРИЧЕСКИ не стоит. Тема мониторится оным разработчиком, а к нам приходят абузы которые нельзя игнорировать.
Статус темы:
Закрыта.
Модераторы: Amazko, Aste
  1. bummm

    bummm

    Регистр.:
    26 июл 2008
    Сообщения:
    443
    Симпатии:
    95
    После переноса галереи проблема с кодировкой...

    Нашел в интернете решение:

    Если Coppermine Photo Gallery в базе содержит текст в кодировке win-1251, а забугорный хостинг показывает все элементы из базы данных как вопросики, то помогает исправить в файле include/functions.inc.php функцию работы с базой данных:
    Код:
    PHP:
    function cpg_db_connect()
    {
            global 
    $CONFIG;
            
    $result = @mysql_connect($CONFIG['dbserver'], $CONFIG['dbuser'], $CONFIG['dbpass']);
            if (!
    $result) {
                    return 
    false;
            }
            if (!
    mysql_select_db($CONFIG['dbname']))
                    return 
    false;
       
    // надо добавить следующую строку:
            
    mysql_query("SET NAMES 'cp1251'",$result); 
            return 
    $result;
    }
    Кодировка в галерее теперь работает, но вот не работает в скрипте MiniCMS...

    А мне надо разместить ссылку только на главной... сделать это можно только с помощью MiniCMS... (или может еще кто-нить способы знает?)


    Заранее спасибо за помощь!
     
Статус темы:
Закрыта.