Импорт из 7.7 в CVS файл

Тема в разделе "Продукты 1C", создана пользователем AVPU, 25 ноя 2010.

  1. AVPU

    AVPU Писатель

    Регистр.:
    11 май 2007
    Сообщения:
    6
    Симпатии:
    2
    Подскажите пожалуйста, можно ли из базы 1С вытянуть всю базу материальных ценностей в CVS файл? Каким образом такое можно сделать? Версия предприятие 7.7
     
  2. dap

    dap Создатель

    Регистр.:
    27 дек 2009
    Сообщения:
    10
    Симпатии:
    22
    вы ничего не путаете? формат векторного изображения или файл изменений????
    Можно подробнее об вашем формате CVS.
    Возможно все
     
  3. laeg

    laeg Создатель

    Регистр.:
    26 авг 2009
    Сообщения:
    48
    Симпатии:
    8
    Меня тоже заинтересовал ИМПОРТ - В CVS

    Может все же ЭКСПОРТ из 1с в CSV (Comma Separated Values) ?
    Если да, то ответ:
    - МОЖНО.
    - Написать обработку по выгрузке.
     
  4. -I-D-

    -I-D- Создатель

    Регистр.:
    16 дек 2009
    Сообщения:
    40
    Симпатии:
    0
    использую CSV в основном для выгрузки из 1С основного прайса (наименование, цена, наличие и т.д. ) для инет-магазина
     
  5. gorenski

    gorenski

    Регистр.:
    12 апр 2007
    Сообщения:
    164
    Симпатии:
    23
    В общих чертах можно сделать так, с выгрузкой группы, наименования и розничной цены.
    PHP:
    Текст СоздатьОбъект("Справочник.Текст");
    Спр СоздатьОбъект("Справочник.Номенклатура");
    СпрЦены СоздатьОбъект("Справочник.Цены");
    Спр.ВыбратьЭлементы();
    Пока Спр.ПолучитьЭлемент() = 1 Цикл
        Если 
    (Спр.ПометкаУдаления() = 1ИЛИ (Спр.ЭтоГруппа() = 1Тогда
            Продолжить
    ;
        
    КонецЕсли;
        
    Стр "" Спр.Родитель ";" Спр ";";
        
    РозничнаяЦена 0;
        
    СпрЦены.ИспользоватьВладельца(Спр.ТекущийЭлемент);
        
    СпрЦены.ВыбратьЭлементы();
        
    Пока СпрЦены.ПолучитьЭлемент() = 1 Цикл
            Если СпрЦены
    .ПометкаУдаления() = 1 Тогда
                Продолжить
    ;
            
    КонецЕсли;

            
    Если СокрЛП(СпрЦены.ТипЦен.Наименование) = "Розничная" Тогда
                РозничнаяЦена 
    СпрЦены.Получить(ТекущаяДата());
                
    Прервать;
            
    КонецЕсли;
        
    КонецЦикла;
        
    Стр Стр РозничнаяЦена;
        
    Текст.ДобавитьСтроку(Стр);
    КонецЦикла;
    Текст.Записать("C:\Temp\catalog.csv");