Помощь ANTISPAM: User ID not valid

Тема в разделе "DLE", создана пользователем s2003r, 3 ноя 2010.

Информация :
Актуальная версия DataLife Engine 11.2
( Final Release v.11.2 | Скачать DataLife Engine | Скачать 11.2 demo )
Нужно ли обновляться | Как обновиться | Изменения в шаблонах
> Нет русских символов <
[Приватная тема DLE (Все подробности в ЛС к модератору раздела)]

Версии 11.1 и ниже - уязвимы!

Локализации | F.A.Q. | Внешний вид
Правила раздела | Правила форума
Обсуждение хайда карается баном!
В каждом сообщении указывайте версию DLE, которого они касаются!
Статус темы:
Закрыта.
Модераторы: killoff
  1. s2003r

    s2003r Постоялец

    Регистр.:
    13 окт 2006
    Сообщения:
    60
    Симпатии:
    4
    Делал поиск по сайту но так и не нашел ответа.
    При попытке отправить персональное сообщение выпадает, ошибка:
    ANTISPAM: User ID not valid

    Дле 9.0

    Помогите советом, кто знает как решить.

    Спасибо.
     
  2. s2003r

    s2003r Постоялец

    Регистр.:
    13 окт 2006
    Сообщения:
    60
    Симпатии:
    4
    покопался в гугле, похоже я не один такой везучий )
    нашел решение для 7.2.
    временное
    1. отключить в админке - "Включить автоматическое блокирование спам программ"
    Зы: не помогло
    2. Найти в:
    engine/modules/addnews.php
    Код:
    $id_key = $$_SESSION['id_key'];
    Заменить на:
    Код:
    $id_key = @$db->safesql($_POST[$_SESSION['id_key']])
    ЗыЗы: тоже не помогло.
    ---
    Хочу заметить что модерация новостей проходит успешно, ошибку выдаёт только при нажатии [отправить] личное сообщение.

    ..копаю дальше.
     
  3. s2003r

    s2003r Постоялец

    Регистр.:
    13 окт 2006
    Сообщения:
    60
    Симпатии:
    4
    тему можно закрыть, решил проблему отчистив кеш firefox :nezn:
     
Статус темы:
Закрыта.