TSite 5.3 баги со статой как поправить?

Тема в разделе "Каталоги, рейтинги, счетчики", создана пользователем airat9000, 1 окт 2010.

  1. airat9000

    airat9000 Создатель

    Регистр.:
    24 апр 2010
    Сообщения:
    30
    Симпатии:
    1
    В общем у скрипта 2 бага

    Не читает хосты и посетителей. Читает тока хиты.:( как быть. Что нужно поправить что бы заработало и прописать
     
  2. evsik

    evsik Постоялец

    Регистр.:
    19 апр 2007
    Сообщения:
    103
    Симпатии:
    12
    help

    тоже столкнулся с таким багом, думал трабл с настройкой nginx но ошибался. Поставил на другой хостинг где только апач - хосты считать не начал. :nezn:
     
  3. sanches812

    sanches812 Писатель

    Регистр.:
    5 сен 2006
    Сообщения:
    5
    Симпатии:
    17
    Такая же была проблема, решил следующим путем:
    в cron_h.php
    $users=mysql_result($last,0,1);
    $hosts=mysql_result($last,0,0);

    поменял на
    $users=mysql_result($last,0,1);
    $hosts=mysql_result($last,0,1);
     
  4. lolfika

    lolfika Постоялец

    Заблокирован
    Регистр.:
    18 окт 2011
    Сообщения:
    43
    Симпатии:
    0
    всоравно Не читает хосты и посетителей
     
  5. Kif

    Kif Создатель

    Регистр.:
    5 авг 2008
    Сообщения:
    43
    Симпатии:
    1
    такая же беда, пробовал то что предложил санчес, но не помогло..
     
  6. Kif

    Kif Создатель

    Регистр.:
    5 авг 2008
    Сообщения:
    43
    Симпатии:
    1
    вот с таким изменением всё заработало

    Код:
    $last=mysql_query("SELECT  count(DISTINCT(log.host)) ,count(DISTINCT(log.sid))
        FROM `log` WHERE log.date>'".$startdate."' and id_user='".$object->memberid."'");
        $users=mysql_result($last,0,0);
        $hosts=mysql_result($last,0,1);
     
  7. lacrimosa

    lacrimosa Писатель

    Регистр.:
    27 апр 2013
    Сообщения:
    1
    Симпатии:
    0
    Kif, спасибо, с этим все заработало!
    у меня такой баг: скрипт не отправляет на мыло письма о регистрации, о смене пароля и т.д., но не работает только на сайте. на локалхосте все нормально работает. в логах sendmail на хостинге отправленные письма фиксируются. получается, что не доходят до получателя.. в чем может быть проблема?