настройка nginx + apache2 backend

Тема в разделе "Администрирование серверов", создана пользователем Madnezz, 22 сен 2010.

Статус темы:
Закрыта.
Модераторы: mefish, stooper
  1. Madnezz

    Madnezz Создатель

    Регистр.:
    14 фев 2010
    Сообщения:
    18
    Симпатии:
    1
    Повесил апач на 81 порт, них на 80, все работает, но если обратиться на 81 порт, то естественно работа уже идет с апачем. так вот как сделать чтобы пользователь видел только nginx на 80 порту или как закрыть 81 порт?
    PHP:
    server {
    listen 80;
    server_name nameserver.ru;
    access_log /var/log/nginx.access_log;
    location ~* \.(jpg|jpeg|gif|png|css|zip|tgz|gz|rar|bz2|doc|xls|exe|pdf|ppt|tar|wav|bmp|rtf|swf|ico|flv|txt|xml|docx|xlsx)$ {
    root /home/www;
    index index.html index.php;
    access_log off;
    expires 30d;
    }
    location ~ /\.ht {
    deny all;
    }
    location / {
    proxy_pass http://127.0.0.1:81/;
    proxy_set_header X-Real-IP $remote_addr;
    proxy_set_header X-Forwarded-for $remote_addr;
    proxy_set_header Host $host;
    proxy_connect_timeout 60;
    proxy_send_timeout 90;
    proxy_read_timeout 90;
    proxy_redirect off;
    proxy_set_header Connection close;
    proxy_pass_header Content-Type;
    proxy_pass_header Content-Disposition;
    proxy_pass_header Content-Length;
    }
    PHP:
    <VirtualHost *:81>
        
    ServerAdmin webmaster@localhost
        DocumentRoot 
    /home/www
        
    <Directory />
            
    Options FollowSymLinks
            AllowOverride None
        
    </Directory>
        <
    Directory /var/www/>
            
    Options Indexes FollowSymLinks MultiViews
            AllowOverride None
            Order allow
    ,deny
            allow from all
        
    </Directory>
        
    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <
    Directory "/usr/lib/cgi-bin">
            
    AllowOverride None
            Options 
    +ExecCGI -MultiViews +SymLinksIfOwnerMatch
            Order allow
    ,deny
            Allow from all
        
    </Directory>
        
    ErrorLog /var/log/apache2/error.log
        
    # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        
    LogLevel warn
        CustomLog 
    /var/log/apache2/access.log combined
        Alias 
    /doc"/usr/share/doc/"
        
    <Directory "/usr/share/doc/">
            
    Options Indexes MultiViews FollowSymLinks
            AllowOverride None
            Order deny
    ,allow
            Deny from all
            Allow from 127.0.0.0
    /255.0.0.0 ::1/128
        
    </Directory>
    </
    VirtualHost>
     
  2. Lexx32

    Lexx32 Создатель

    Регистр.:
    8 янв 2007
    Сообщения:
    39
    Симпатии:
    19
    1 вариант в конфиге апача
    /etc/httpd/conf/httpd.conf
    найти Listen 80 и поменять на Listen 81
    2 вариант
    прибить через iptables
    iptables -A INPUT -s 127.0.0.1 -d 127.0.0.1 -j ACCEPT
    iptables -A INPUT tcp --dport 80 -j DROP
     
  3. wal

    wal Постоялец

    Регистр.:
    24 мар 2008
    Сообщения:
    89
    Симпатии:
    30
    заставить апач работать только на 127.0.0.1

    вместо <VirtualHost *:81> нужно прописать
    <VirtualHost 127.0.0.1:81> - должно помочь...
     
  4. Madnezz

    Madnezz Создатель

    Регистр.:
    14 фев 2010
    Сообщения:
    18
    Симпатии:
    1
    Спс что дали направление мысли, сделал так:
    В /etc/apache2/ports.conf прописал:

    NameVirtualHost *:81
    Listen 127.0.0.1:81
     
Статус темы:
Закрыта.