Помощь Новые фичи DLE 9

Тема в разделе "DLE", создана пользователем daniilcraciun, 5 сен 2010.

Информация :
Актуальная версия DataLife Engine 11.2
( Final Release v.11.2 | Скачать DataLife Engine | Скачать 11.2 demo )
Нужно ли обновляться | Как обновиться | Изменения в шаблонах
> Нет русских символов <
[Приватная тема DLE (Все подробности в ЛС к модератору раздела)]

Версии 11.1 и ниже - уязвимы!

Локализации | F.A.Q. | Внешний вид
Правила раздела | Правила форума
Обсуждение хайда карается баном!
В каждом сообщении указывайте версию DLE, которого они касаются!
Статус темы:
Закрыта.
Модераторы: killoff
  1. daniilcraciun

    daniilcraciun Писатель

    Регистр.:
    22 фев 2009
    Сообщения:
    6
    Симпатии:
    0
    Обновился я на DLE 9. Сделал всё по инструкции, загрузил специальный шаблон для отображения так называемого формуляра пользователя. Отредактировал css файлы, добавив новое и убрав то, что написано убрать. Загрузил изображения новые.
    Вроде всё правильно, но почему-то перестал работать спойлер, в добавлении комментов не открывается окошко со смайлами и выбором цвета, а также когда жму на автора новости пишет "Загрузка...Подождите", ну а потом загрузка завершается, а формуляр не показывается.
    Со стандартным шаблоном всё в норме. Что тогда это может быть? Я уже 10 раз проверил все эти изменения в шаблонах, поэтому разочарован.
     
  2. Klepach

    Klepach

    Регистр.:
    31 окт 2008
    Сообщения:
    941
    Симпатии:
    250
    без пациента врядли кто тебе подскажет в чём лажа.
     
  3. daniilcraciun

    daniilcraciun Писатель

    Регистр.:
    22 фев 2009
    Сообщения:
    6
    Симпатии:
    0
    Что нужно предоставить? Я действительно хочу решить, в чём проблема.
     
  4. maks1192

    maks1192 Писатель

    Регистр.:
    7 июн 2009
    Сообщения:
    5
    Симпатии:
    1
    ну что тут не понятного... сайт нужен. напиши ссылку на сайт
     
  5. daniilcraciun

    daniilcraciun Писатель

    Регистр.:
    22 фев 2009
    Сообщения:
    6
    Симпатии:
    0
    У кого схожая проблема, уберите все запросы jquery из шаблона и модулей.
     
  6. yavasilek

    yavasilek vasilek_gorbunok

    Регистр.:
    5 окт 2008
    Сообщения:
    1.178
    Симпатии:
    423
    точнее сказать наверное не запросы, а все места подключения, т.к. теперь это встроеная фича.
     
  7. -=MaD_DoG=-

    -=MaD_DoG=- Постоялец

    Регистр.:
    26 янв 2010
    Сообщения:
    55
    Симпатии:
    10
    Открыть engine/classes/parse.class.php
    Заменить (в 2ух местах:(
    Код
    Код:
    ShowOrHide('" . $id_spoiler . "')
    На:
    Код
    Код:
    ToggleSpoiler('" . $id_spoiler . "')
    2. Открыть engine/classes/js/js_edit.js
    Новый спойлер с эффектом затухания (fade) + скорость выше
    В конце вставить:
    Код
    Код:
    function ToggleSpoiler(a){var c=$("#"+a);a=document.getElementById("image-"+a)?document.getElementById("image-"+a):null;if(c.css("display")=="none"){c.show("fade",{},'medium');if(a)a.src=dle_root+"templates/"+dle_skin+"/dleimages/spoiler-minus.gif"}else{c.hide("fade",{},'medium');if(a)a.src=dle_root+"templates/"+dle_skin+"/dleimages/spoiler-plus.gif"}}
     
  8. twirkt

    twirkt Писатель

    Регистр.:
    14 сен 2009
    Сообщения:
    4
    Симпатии:
    0
    В main.tpl поищи вот это
    <script type="text/javascript" src="{THEME}/js/jquery-pack.js"></script> если имеется такое просто удали и все должно работать у меня была схожая проблема из за этой строки!
    Только у меня выглядела так:<script type="text/javascript" src="{THEME}/js/jquery-1.2.6.pack.js"></script>
     
Статус темы:
Закрыта.