Interspire Shopping Cart + jQuery >= v1.4

Тема в разделе "Интернет-магазины", создана пользователем oleynikd, 11 авг 2010.

Статус темы:
Закрыта.
  1. oleynikd

    oleynikd Создатель

    Регистр.:
    16 сен 2009
    Сообщения:
    28
    Симпатии:
    0
    Пользуюсь isc уже давненько, решил добавить парочку новых фич себе и, естественно, выбрал jQuery как фреймворк. Но вот по вылазило кучу проблем!
    В isc стоял jQuery v1.2.6 который уже давненько устарел, я поставил v1.4 и началось.....:confused:
    Основная проблема - перестали работать опции товаров, если их больше 2-х. Вот например при покупке iPod человеку нужно выбрать его память и цвет. Так вот если в продукте выставлять только выбор одной опции все работает, а если 2 и больше - перестает работать, товар купить не возможно - постоянно выдает ошибки что не делай....
    Уважаемые ГУРУ, помогите!!! Может кто сталкивался с подобной проблемой?
    :bc::bc::bc::bc::bc::bc::bc::bc::bc:
     
  2. oleynikd

    oleynikd Создатель

    Регистр.:
    16 сен 2009
    Сообщения:
    28
    Симпатии:
    0
    Никто не ответил, пришлось самому разобраться.

    закомментил, не понятную (по логике она в принципе не нужна) строку
    Код:
    previousSelection = previous.getCombination();
    в файле produjt.js и все заработало.
     
  3. MARDEN

    MARDEN Постоялец

    Регистр.:
    18 ноя 2006
    Сообщения:
    81
    Симпатии:
    7
    Достаточно посмотреть на консоль ошибок, чтобы понять, что за ошибка и где она возникает.
     
Статус темы:
Закрыта.