Пропадает лого сайта в IE6

Тема в разделе "Веб-дизайн", создана пользователем alexks, 30 июл 2010.

Статус темы:
Закрыта.
Модераторы: zek24
  1. alexks

    alexks Создатель

    Регистр.:
    19 апр 2010
    Сообщения:
    27
    Симпатии:
    0
    Сайт
    В верхнем левом углу - лого. Куда оно исчезает в IE6??
    Пробовал брать див в рамку и двигать его margin'ами, padding'ами, left, top - ноль реакции. Лого просто наглухо перекрыто...
    Оно пропало после изменений соседнего с ним меню.
    Кто знает в чем косяк? Как пофиксить не разрушая существующей структуры.
     
  2. postal_w

    postal_w Писатель

    Регистр.:
    27 апр 2009
    Сообщения:
    4
    Симпатии:
    0
    думаю иешку торчит от height: 1% в #logo
    как вариант поставьте логотипу z-index: 100;
     
  3. alexks

    alexks Создатель

    Регистр.:
    19 апр 2010
    Сообщения:
    27
    Симпатии:
    0
    Попробовал
    div#logo {
    height:148px !important;
    z-index: 100 !important;
    }

    не реагирует :ac:
     
  4. Delk0

    Delk0

    Регистр.:
    26 мар 2010
    Сообщения:
    288
    Симпатии:
    57
    Уберите свойство float:left в описании #logo.
    Во-первых ие его очень не любит.
    Во-вторых у вас абсолютное позиционирование.
     
  5. alexks

    alexks Создатель

    Регистр.:
    19 апр 2010
    Сообщения:
    27
    Симпатии:
    0
    сделал float: none !important;
    IE не отреагировал. А позиционирование да, абсолютное.

    PS: там под разные браузеры могут быть небольшие отличия в стилях. На всякий случай если кто-то в фаербаге смотрит
    PPS: есть подозрение что этот див просто соскакиевает вниз, потому-что ему не хватает места с меню.


    PPPS:
    Пофиксил!
    Вот такой вещью
    div#header_r {
    width:780px;
    }
    Таки действительно, без указания ширины, лого перескакивало вниз из-за нехватки места в контейнере...
    Всем спасибо за внимание к теме
     
  6. machoman

    machoman Постоялец

    Регистр.:
    31 янв 2007
    Сообщения:
    54
    Симпатии:
    10
    У меня до сих пор в IE6 лого не отображается (вернее, из 10 F5-чек отразился 2 раза). Попробовал вместо него (CSArch_logo_white.png) вставить CSArch_logo_black_rev.jpg - отобразился. Это процентов 90% трабл со скриптом, обрабатывающим PNG с прозрачностью в IE - /templates/rhuk_milkyway/css/unitpngfix.js. Потому что его убрал, лого появилось.
     
  7. alexks

    alexks Создатель

    Регистр.:
    19 апр 2010
    Сообщения:
    27
    Симпатии:
    0
    Да? Странно... у меня вроде больше не пропадает. (раз 10 попробовал). У меня IE6 не IEtester.
    Во всяком случае, это уже другая песня... Jquery может подглючивает...
     
  8. dimas19

    dimas19 Создатель

    Регистр.:
    18 июл 2010
    Сообщения:
    20
    Симпатии:
    7
    проверьте на валидаторе валидность кода.
    Исправляйте ошибки.
     
Статус темы:
Закрыта.