1. Уважаемые пользователи, прежде чем ответить в теме или создать новую,
    внимательно ознакомьтесь с правилами раздела

    Кому лень работать или руки не оттуда - пользуйтесь услугами специалистов
  2. Не задавайте глупых вопросов "Посоветуйте какой-нибудь компонент.."

    Есть JED!!! Ищите там!!!

Проблема с SEO-ссЬІлками

Тема в разделе "Joomla", создана пользователем Paulus, 25 июн 2010.

Информация :
  • Уважаемые пользователи, прежде чем ответить в теме или создать новую, внимательно ознакомьтесь с правилами раздела
  • Не задавайте глупых вопросов "Посоветуйте какой-нибудь компонент.." Есть JED!!! Ищите там!!!
  • Аналоги ищите там же - на JED!!!
  • Новая версия? - У кого будет - тот выложит!
Статус темы:
Закрыта.
Модераторы: arman29, DMS, Genk0, NightHunter
  1. Paulus

    Paulus Постоялец

    Регистр.:
    9 сен 2008
    Сообщения:
    131
    Симпатии:
    11
    Когда в конфігурациях ставлю оптимизировать для поисковиков, на сайте не отображает шаблон, просто текст без ничего.
    Что сделать?
     
  2. Mithgollor

    Mithgollor

    Регистр.:
    14 апр 2010
    Сообщения:
    168
    Симпатии:
    37
    Что за настройка такая? Может ты имеешь ввиду "Включить SEF-ссылки (ЧПУ)"? Если да то после включения его переименуй файл htaccess.txt находящийся в корне сайта на .htaccess
     
    Paulus нравится это.
  3. Paulus

    Paulus Постоялец

    Регистр.:
    9 сен 2008
    Сообщения:
    131
    Симпатии:
    11
    Не помогло...
     
  4. Mithgollor

    Mithgollor

    Регистр.:
    14 апр 2010
    Сообщения:
    168
    Симпатии:
    37
    Оптимизаторы разные не ставил? Типа ВебоСайтСпидАп? Или что-то похожее. Которые css и javascript объединяют в один файл. Попробуй еще кеш очистить.
     
  5. Paulus

    Paulus Постоялец

    Регистр.:
    9 сен 2008
    Сообщения:
    131
    Симпатии:
    11
    Ничего, чистая джумля 1.5.18.
    Кэш чистил ы с другого компа заходил.
     
  6. Alisandre78

    Alisandre78 Постоялец

    Регистр.:
    16 дек 2008
    Сообщения:
    144
    Симпатии:
    36
    Опубликуй плагин сеф раньше чем плагин систем кеш. Т.е. задай порядок - сначала сеф, потом кеш, тогда он правильно будет обрабатывать. По крайней мере у меня была ситуация такая. Рецепт - только для того случая когда включено кеширование.
     
  7. 3ner

    3ner

    Регистр.:
    21 июн 2009
    Сообщения:
    757
    Симпатии:
    197
    Проверь в .htaccess # RewriteBase / - убери #
     
    Paulus нравится это.
  8. Paulus

    Paulus Постоялец

    Регистр.:
    9 сен 2008
    Сообщения:
    131
    Симпатии:
    11
    Там такой строчки вообще нету.
    А проблема, как мне кажется, в том, что в УРЛ сразу после домена и перед названием, например, компонента, прописывается /index.php/
     
  9. rui

    rui

    Регистр.:
    24 янв 2008
    Сообщения:
    155
    Симпатии:
    44
    дык, включи mod_rewrite в настройках компонента, который ты используешь, например в sh404sef.
     
    Paulus нравится это.
  10. 3ner

    3ner

    Регистр.:
    21 июн 2009
    Сообщения:
    757
    Симпатии:
    197
    Должна быть, в любом случае.
    Для стандартного SEF, в .htaccess должно быть так:
    HTML:
    
    Options +FollowSymLinks
    RewriteEngine On
    RewriteBase /
    ## Deny access to extension xml files (uncomment out to activate)
    #<Files ~ "\.xml$">
    #Order allow,deny
    #Deny from all
    #Satisfy all
    #</Files>
    ## End of deny access to extension xml files
    RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|\%3D) [OR]
    RewriteCond %{QUERY_STRING} base64_encode.*\(.*\) [OR]
    RewriteCond %{QUERY_STRING} (\<|%3C).*script.*(\>|%3E) [NC,OR]
    RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
    RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
    RewriteRule ^(.*)$ index.php [F,L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_URI} !^/index.php
    RewriteCond %{REQUEST_URI} (/|\.php|\.html|\.htm|\.feed|\.pdf|\.raw|/[^.]*)$  [NC]
    RewriteRule (.*) index.php
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
    
    Еще проверь, задействован ли mod_rewrite а Апаче.
    В крайнем случае в configuration.php пропиши var $live_site = "http://www.mysite.ru";
     
Статус темы:
Закрыта.