1. Уважаемые пользователи, прежде чем ответить в теме или создать новую,
    внимательно ознакомьтесь с правилами раздела

    Кому лень работать или руки не оттуда - пользуйтесь услугами специалистов
  2. Не задавайте глупых вопросов "Посоветуйте какой-нибудь компонент.."

    Есть JED!!! Ищите там!!!

Переход Joomla 1.x на 1.5

Тема в разделе "Joomla", создана пользователем Darkness2010, 14 июн 2010.

Информация :
  • Уважаемые пользователи, прежде чем ответить в теме или создать новую, внимательно ознакомьтесь с правилами раздела
  • Не задавайте глупых вопросов "Посоветуйте какой-нибудь компонент.." Есть JED!!! Ищите там!!!
  • Аналоги ищите там же - на JED!!!
  • Новая версия? - У кого будет - тот выложит!
Статус темы:
Закрыта.
Модераторы: arman29, DMS, Genk0
  1. Darkness2010

    Darkness2010 Создатель

    Регистр.:
    25 фев 2010
    Сообщения:
    36
    Симпатии:
    2
    Подскажите пожалуйста, как правильно перенести сайта с Joomla 1.x на 1.5?
     
  2. Darkness2010

    Darkness2010 Создатель

    Регистр.:
    25 фев 2010
    Сообщения:
    36
    Симпатии:
    2
    Нашел решение, проверил, работает. Для тех кому необходимо перенести свой сайт на Joomla 1.5, почитайте отличную статью вот по этой ссылке http://www.eldia.org.ua/stati/15-stati-po-joomla/47-migration-joomla.html
     
  3. bootlegger

    bootlegger Создатель

    Регистр.:
    20 апр 2010
    Сообщения:
    43
    Симпатии:
    12
    Вот здесь описаны два способа, с помощью компонентов и вручную.

    http://joomlaportal.ru/content/view/1830/53/
     
  4. Роза Люксембург

    Роза Люксембург Постоялец

    Регистр.:
    5 фев 2009
    Сообщения:
    106
    Симпатии:
    16
    Доброе время суток. Несколько дней пытаюсь перенести корректно сайт с ветки 1.0 на 1.5, но пока безуспешно. проблема заключается в том, что и com_migrator и com_mtwmigrator не переносят компоненты, которые использованы у меня, так как префикс в ДБ - не jos_ Подскажите, пожалуйста, в чем основное различие между ДБ старой и новой дж., и как, вообще, перенести все на 1.5 вручную. Спасибо.
     
  5. 3ner

    3ner

    Регистр.:
    21 июн 2009
    Сообщения:
    757
    Симпатии:
    197
    Префикс jos_ используется всегда.
    В данном случае есть 2 варианта:
    Скачиваем БД к себе, переименовываем префикс в jos_, имопртируем обратно, в конфиг файле указываем новый префикс и стандартно используем миграторы.
    Альтернативный способ - заменить jos_ в миграторах на свой и пользоваться уже ими.
     
    Роза Люксембург нравится это.
  6. Роза Люксембург

    Роза Люксембург Постоялец

    Регистр.:
    5 фев 2009
    Сообщения:
    106
    Симпатии:
    16
    Спасибо. Попробую. Глупый, наверное, вопрос, но... будут ли работать корректно на 1.5 в легаси компоненты и модули от 1.0. Или же могут и не заработать и опять придется все переделывать? У меня главное - в компонентах, а не в материалах..
     
  7. 3ner

    3ner

    Регистр.:
    21 июн 2009
    Сообщения:
    757
    Симпатии:
    197
    В legacy компоненты и модули работать будут, на сколько корректно неизвестно, каждый раз по разному.
    Лучше legacy никогда не использовать - меньше глюков, быстрее работать будет.
     
  8. Роза Люксембург

    Роза Люксембург Постоялец

    Регистр.:
    5 фев 2009
    Сообщения:
    106
    Симпатии:
    16
    А чем именно отличаются расширения для этих 2-х веток? Запросами к БД (и еще бы знать в чем разница)? или есть еще что-то? Мне не лень переделать под нейтив. Только бы знать что именно переделать нужно...
     
  9. 3ner

    3ner

    Регистр.:
    21 июн 2009
    Сообщения:
    757
    Симпатии:
    197
    Во-первых уже тут обсуждалось
    http://www.nulled.ws/showthread.php?t=54954
    Потом тут
    http://joomlaforum.ru/index.php/topic,44789.0/all.html
    В двух словах: Разница в написании расширений, разница использования БД, разница форматирования шаблонов.

    Переносить нужно все. Ядро переносится без проблем, а расширения придется ставить и настраивать снова (конвертеры БД их тоже не всегда хорошо переносят).
    Но делать или нет решать тебе.

    Грубо говоря (подытожим:(
    Использование legacy в joomla 1.5 равносильно запуску эмулятора PS2 на крутом PC - как бы работает, а результат сомнительный.
     
  10. ftgroup

    ftgroup Создатель

    Регистр.:
    8 фев 2008
    Сообщения:
    21
    Симпатии:
    2
    Долго мучалась с переносом наконец то сделала. У меня на сайте еще и много своих переделок было.
     
Статус темы:
Закрыта.