1. Важное и срочное обновление IPB 3.4.5 - https://nulled.cc/threads/243375/

[Помощь] перенос IPB - проблемы

Тема в разделе "IPB", создана пользователем ertog, 4 июн 2010.

Статус темы:
Закрыта.
Модераторы: Maybe
  1. ertog

    ertog

    Регистр.:
    2 авг 2007
    Сообщения:
    688
    Симпатии:
    45
    Перенес IPB форум с одного сервера на другой простым копированием всей директории по фтп и перезеливкой дампа базы. перепрописал config. После всего этого главная страница форума стоит абсолютно пустая.... и никаких ошибок найти не могу.... При этом в админку вхожу нормально и там тоже никаких ошибок нету....
     
  2. UDAV

    UDAV

    Регистр.:
    22 июн 2007
    Сообщения:
    776
    Симпатии:
    153
    Проверь файл конфига, возможно удалил какой-то важный символ. Или верни конфиг от старого домена, если опять все белое будет, а не mysql ошибка, то будем думать где еще допустил ошибку.
     
  3. Fridhelm

    Fridhelm Читатель

    Заблокирован
    Регистр.:
    15 авг 2009
    Сообщения:
    211
    Симпатии:
    13
    Кодировка БД совпадает со старой ?
     
  4. UDAV

    UDAV

    Регистр.:
    22 июн 2007
    Сообщения:
    776
    Симпатии:
    153
    Кодировка тут вообще не причем.
     
  5. eXtriDer

    eXtriDer Создатель

    Регистр.:
    11 апр 2009
    Сообщения:
    32
    Симпатии:
    1
    Была подобная ситуация, на одном сервере ипб работал, на втором нет
    Проблема была как раз в кодировке, ведь 3 версия работает на utf8.
    Нужно прописать в htaccess кодировку сайта utf-8
     
  6. cmwork

    cmwork Постоялец

    Регистр.:
    10 сен 2009
    Сообщения:
    120
    Симпатии:
    23
    Если на Mysql разные кодировки - такая проблема бывает
     
  7. ertog

    ertog

    Регистр.:
    2 авг 2007
    Сообщения:
    688
    Симпатии:
    45
    а в htacces где прописывать?

    еще раз

    Перенес IPB форум с одного сервера на другой простым копированием всей директории по фтп и перезеливкой дампа базы. перепрописал conf_global.php

    Было
    <?php
    $INFO['sql_driver'] = 'mysql';
    $INFO['sql_host'] = 'localhost';
    $INFO['sql_database'] = 'имя_ibp';
    $INFO['sql_user'] = 'имя_ibp';
    $INFO['sql_pass'] = 'пароль;
    $INFO['sql_tbl_prefix'] = '';
    $INFO['sql_debug'] = '1';
    $INFO['sql_charset'] = 'utf8';
    $INFO['board_start'] = '1275122737';
    $INFO['installed'] = '1';
    $INFO['php_ext'] = 'php';
    $INFO['safe_mode'] = '0';
    $INFO['board_url'] = 'http://имя сайта/IBP';
    $INFO['banned_group'] = '5';
    $INFO['admin_group'] = '4';
    $INFO['guest_group'] = '2';
    $INFO['member_group'] = '3';
    $INFO['auth_group'] = '1';
    $INFO['use_friendly_urls'] = '1';
    $INFO['_jsDebug'] = '0';
    $INFO['mysql_tbl_type'] = 'MyISAM';

    define('IN_DEV', 0);

    ?>



    Стало

    <?php
    $INFO['sql_driver'] = 'mysql';
    $INFO['sql_host'] = 'localhost';
    $INFO['sql_database'] = ' имя _ibp';
    $INFO['sql_user'] = ' имя _ibp';
    $INFO['sql_pass'] = 'пароль;
    $INFO['sql_tbl_prefix'] = '';
    $INFO['sql_debug'] = '1';
    $INFO['sql_charset'] = 'utf8';
    $INFO['board_start'] = '1275122737';
    $INFO['installed'] = '1';
    $INFO['php_ext'] = 'php';
    $INFO['safe_mode'] = '0';
    $INFO['board_url'] = 'http://otdix.имя.ru/';
    $INFO['banned_group'] = '5';
    $INFO['admin_group'] = '4';
    $INFO['guest_group'] = '2';
    $INFO['member_group'] = '3';
    $INFO['auth_group'] = '1';
    $INFO['use_friendly_urls'] = '1';
    $INFO['_jsDebug'] = '0';
    $INFO['mysql_tbl_type'] = 'MyISAM';

    define('IN_DEV', 0);

    ?>
    . После всего этого главная страница форума стоит абсолютно пустая.... и никаких ошибок найти не могу.... При этом в админку вхожу нормально и там тоже никаких ошибок нету....
     
  8. TheStig

    TheStig Создатель

    Регистр.:
    21 мар 2010
    Сообщения:
    36
    Симпатии:
    4
    Проверь все ли файлы ты залил
     
  9. ertog

    ertog

    Регистр.:
    2 авг 2007
    Сообщения:
    688
    Симпатии:
    45
    да все .
     
  10. ertog

    ertog

    Регистр.:
    2 авг 2007
    Сообщения:
    688
    Симпатии:
    45
    написал в саппорт хостинга вот такой ответ получил

    Здравствуйте, включил вывод ошибок PHP, сейчас видно ошибку,
    Ошибка 'Не удалось инициализировать регистр, кеш настроек либо пуст, либо испорчен
    что делать?
    подскажите ,сделайте доброе дело
     
Статус темы:
Закрыта.