Помогите с php!

Тема в разделе "Администрирование серверов", создана пользователем Tele2, 12 май 2010.

Статус темы:
Закрыта.
Модераторы: mefish, stooper
  1. Tele2

    Tele2

    Регистр.:
    14 апр 2006
    Сообщения:
    784
    Симпатии:
    94
    попытался обновить php с 5.2 до 5.3.2 и сделал это криво, вылезают такие ошибки:

    Есть проблемы такие:

    ни хрена не понимаю,
    date.timezone = "Europe/Moscow"
    Не помогает
     
  2. Yozik

    Yozik

    Регистр.:
    5 дек 2007
    Сообщения:
    239
    Симпатии:
    65
    Так ясно же написано - нужно настроить php.ini, т.е. раскомментировать строчки настроек.
     
  3. Tele2

    Tele2

    Регистр.:
    14 апр 2006
    Сообщения:
    784
    Симпатии:
    94
    Спасибо Кэп!
    Поясни какие строки надо раскоментировать.
     
  4. Conwell

    Conwell

    Регистр.:
    23 мар 2009
    Сообщения:
    337
    Симпатии:
    177
    Можно нескромный вопрос: "Зачем вы сделали это?" (лирика)
    Как минимум конфликт Zend Extension Manager с новой версией php 5.3, остальное - последствия.
    Перед тем как что-то делать (обновления в частности) почитайте документы установки и обновления, там обычно все хорошо расписано как и что надо исправлять.
    Откатывайтесь обратно на 5.2 если необходимость в 5.3 "просто чтобы было".
     
  5. mefish

    mefish Support

    Moderator
    • Супермодератор
    Регистр.:
    30 авг 2007
    Сообщения:
    915
    Симпатии:
    643
    круто, пых обновили, а либы пускай сами :D

    yum update php*

    зы: а вообче не нужно, не комильфо есче ,хотя если такая уж потребность, то да :)
     
  6. rootden

    rootden Создатель

    Регистр.:
    8 май 2010
    Сообщения:
    34
    Симпатии:
    1
    тс зря обновляешь.рано еще на свежие версии прыгать.если не решил вопрос асю в личку.
     
  7. Tele2

    Tele2

    Регистр.:
    14 апр 2006
    Сообщения:
    784
    Симпатии:
    94
    у меня фря ... Я там полностью все пробовал удалять, чистить и ... нифига.
     
  8. -Alighieri-

    -Alighieri- Создатель

    Регистр.:
    2 мар 2010
    Сообщения:
    17
    Симпатии:
    0
    Я думаю вам стоит полностью переустановить PHP и вернуть версию 5.2, ибо версия 5.3 очень сырая, и не стабильно работающая. :)
    Есть даже неплохая статейка http://judge.kiev.ua/index.php?newsid=15
     
  9. Tele2

    Tele2

    Регистр.:
    14 апр 2006
    Сообщения:
    784
    Симпатии:
    94
    5.3 не сырая и стабильная версия. Давно посещал php.net?

    Ошибка была простейшая. При обновлении php, я не удалил старые модули пхп, которые устанавливал вручную, следовательно:

    # cd /usr/ports/lang/php5-extensions && make deinstall && cd ../../ && pkg_info | grep php*

    Получил список того, что не удалилось, и вручную, все удалил.

    +непонятно как, обовился файл php.ini и стало error_reporting = E_ALL

    :D

    и все стало норма.

    Да и пришлось еще обновить Zend optimizer, так как сначала, он у меня установился только для версии 5.2.x
     
Статус темы:
Закрыта.