Zend Guard генерит код для которого нужен zend engine 3.X для которого нужен PHP6...

Тема в разделе "PHP", создана пользователем newbigmir, 15 апр 2010.

Статус темы:
Закрыта.
Модераторы: latteo
  1. newbigmir

    newbigmir

    Регистр.:
    31 июл 2007
    Сообщения:
    283
    Симпатии:
    23
    Zend Guard 5.0 генерит код для которого нужен zend engine 3.X для которого нужен PHP6...

    хостинг с php 5.2.X/mysql

    пишу в саппорт хостинга что б обновили zendengine с 2.2 до 3.3 так как ZendGuard 5.0 генерит код для которого нужен минимум 3.3.3

    в ответ что 2.2 это последня версия, а 3.3 для php6 но так как он еще не стабилен то php6 пока ставить не будут.

    Что делать что б юзать защищенные zendom файлы ?
     
  2. sidxx55

    sidxx55 IC, SG-PS decoding, encoding

    Регистр.:
    12 май 2007
    Сообщения:
    318
    Симпатии:
    208
    ты ничего не напутал?? движок зенда и оптимайзер??:read:
     
  3. newbigmir

    newbigmir

    Регистр.:
    31 июл 2007
    Сообщения:
    283
    Симпатии:
    23
    какой версией zenda нужно шифровать файлы что б они работали на 2.2 ?
    или что нужно обновить что б заработало?

    чета я не понимаю
    Перейти по ссылке

    Zend Guard 5.0.1
    Zend Optimizer 3.3.3

    что должно стоять на сервере и почему zend 2.2 не подходит?
     
  4. sidxx55

    sidxx55 IC, SG-PS decoding, encoding

    Регистр.:
    12 май 2007
    Сообщения:
    318
    Симпатии:
    208
    кодер 5 версии кодирует только пхп 4 и 5 версию - он не кодирует для пхп 6, так что последний оптимайзер должен подходить, кодирешь для пхп 5, посмотри для начала пхп инфо кофиг сервра
     
  5. newbigmir

    newbigmir

    Регистр.:
    31 июл 2007
    Сообщения:
    283
    Симпатии:
    23
    Linux
    PHP Version 5.2.X
    Zend Scripting Language Engine:
    Zend Engine v2.2.0, Copyright (c) Zend Technologies


    Вот сгенерированный код:
    Код:
    Zend�2004072203�3�175�444�xщ џ2ХкAщy ѕ‰yy©•р4QЗeldjdjf,JАХJinnҐ^bJJґ‡ЄѓИ"'ї iZ�ZЯ02АZ‘PЫ?B64 иЃЄ�Њ^‚VPл(i‚f>T-Tлtx6Gnf@%]1lfѓж;`BAЯ¬Мnj•D”лЖи’f№р�CЛРЦ—ЦJ* ЌZTNg™¦fЖЖж& �к)Я
    в браузере выбрасывает тупо код.
     
  6. newbigmir

    newbigmir

    Регистр.:
    31 июл 2007
    Сообщения:
    283
    Симпатии:
    23
    у всех работает нормально и глюки только у меня?

    на Денвере тоже самое. просто выбрасывает зашифрованный код.

    :bc:
     
  7. jenya777777

    jenya777777 Создатель

    Регистр.:
    13 май 2010
    Сообщения:
    15
    Симпатии:
    0
    на сайте denwer.ru скачай сборку с уже установленным Zend Optimizer, сразу подобные проблемы отпадут
     
Статус темы:
Закрыта.