[Помощь] Пропадают заголовки колонок при импорте CSV

Тема в разделе "WebAsyst", создана пользователем Pupsyan, 8 апр 2010.

Статус темы:
Закрыта.
Модераторы: mdss
  1. Pupsyan

    Pupsyan Создатель

    Регистр.:
    28 фев 2009
    Сообщения:
    29
    Симпатии:
    1
    После переезда на другой сервер: загружаю файл, он его как обычно парсит и выводит какие колонки он нашел.
    Так вот заголовки колонок которые начинаются с кириллических символов он видит, но их названия превращается в пустую строку.
    Конкретно:
    Код:
    В CSV-файле найдено 10 колонок
    ID страницы, META keywords, META description, 
    
    В HTML выглядит так:
    HTML:
    <div style="color:#555; padding: 15px; text-style: italic; background-color: #f3f3f3"><span style="font-style:italic;background-color:#eee;padding:0px;margin:10px 2px;">ID страницы</span>, <span style="font-style:italic;background-color:#eee;padding:0px;margin:10px 2px;">META keywords</span>, <span style="font-style:italic;background-color:#eee;padding:0px;margin:10px 2px;">META description</span>, <span style="font-style:italic;background-color:#eee;padding:0px;margin:10px 2px;"></span></div>
    Если попробовать все заголовки колонок перевести в латиницу, все найдет и отобразит, но при самом импорте скрипт отвалится.
    Пробовал разные кодировки файлов, пробовал также этот же CSV грузить на старый сервер - там все нормально.
    Установлено "AddDefaultCharset utf-8", как и на старом сервере.

    В чем может быть проблема?
     
  2. fiker

    fiker Постоялец

    Регистр.:
    1 мар 2010
    Сообщения:
    61
    Симпатии:
    19
    полюбому в кодировке вопрос только где пробуй в cp1251 у меня точно в ней работает в какой кодировке у тебя база?
     
Статус темы:
Закрыта.