Помощь UTF8 проблема

Тема в разделе "DLE", создана пользователем NaNoN, 25 фев 2010.

Информация :
Актуальная версия DataLife Engine 11.3
( Final Release v.11.3 | Скачать DataLife Engine | Скачать 11.3 demo )
Нужно ли обновляться | Как обновиться | Изменения в шаблонах
> Нет русских символов <
[Приватная тема DLE (Все подробности в ЛС к модератору раздела)]

Версии 11.2 и ниже - уязвимы!

Локализации | F.A.Q. | Внешний вид
Правила раздела | Правила форума
Обсуждение хайда карается баном!
В каждом сообщении указывайте версию DLE, которого они касаются!
Статус темы:
Закрыта.
Модераторы: killoff
  1. NaNoN

    NaNoN Создатель

    Регистр.:
    6 мар 2009
    Сообщения:
    12
    Симпатии:
    0
    Привет всем. Я решил обновить дле 8,2 на 8,3 и за одно перекодировку изменит с cp1251 на UTF8. Все прошло вроде нормально. Но в админке когда используешься с редактором WYSIWYG Некоторые буквы отправляется на SQL как код.

    ö = uuml;
    ü = ouml
    ç = ccedil

    Другие все нормально. Это можно исправит или так должна быт?
     
  2. PoMaH

    PoMaH

    Регистр.:
    8 июн 2006
    Сообщения:
    753
    Симпатии:
    142
    WYSIWYG править нужно, это он конвертирует
     
  3. raven4eg

    raven4eg Бесяцая птича

    Регистр.:
    14 дек 2007
    Сообщения:
    148
    Симпатии:
    19
    Прошу прощения, но когда DLE стал работать с UTF-8?
    Ведь были же только эксперименты, которые заканчивались всегда не очень удачно и с более серьёзными ошибками, нежели у ТС?
     
    NaNoN нравится это.
  4. aDolph

    aDolph Создатель

    Регистр.:
    20 апр 2009
    Сообщения:
    21
    Симпатии:
    6
    raven4eg, русским же языком написано, что он сам сменил кодировку.
    NaNoN, дождись выхода 8.5. Не долго уже осталось.
     
    NaNoN нравится это.
  5. Drimius

    Drimius Создатель

    Регистр.:
    22 май 2008
    Сообщения:
    10
    Симпатии:
    1
    Гхмм ну не знаю. Я тоже у себя менял кодировку на UTF-8, но у меня всё нормально работает и не глючит. Расскажу способ как я это делал может поможет. 1: Все файлы движка, включая JS и темплейты, перекодировал в UTF8 w/o BOM, перевёл базу в UTF8 ну собственно и всё. Уже 2 недели как работает и всё ок.
     
    NaNoN нравится это.
Статус темы:
Закрыта.