1. Уважаемые пользователи, прежде чем ответить в теме или создать новую,
    внимательно ознакомьтесь с правилами раздела

    Кому лень работать или руки не оттуда - пользуйтесь услугами специалистов
  2. Не задавайте глупых вопросов "Посоветуйте какой-нибудь компонент.."

    Есть JED!!! Ищите там!!!

Помогите Fatal error: Call to a member function get() on a non-objec

Тема в разделе "Joomla", создана пользователем nikoter, 23 фев 2010.

Информация :
  • Уважаемые пользователи, прежде чем ответить в теме или создать новую, внимательно ознакомьтесь с правилами раздела
  • Не задавайте глупых вопросов "Посоветуйте какой-нибудь компонент.." Есть JED!!! Ищите там!!!
  • Аналоги ищите там же - на JED!!!
  • Новая версия? - У кого будет - тот выложит!
Статус темы:
Закрыта.
Модераторы: arman29, DMS, Genk0
  1. nikoter

    nikoter

    Регистр.:
    29 май 2008
    Сообщения:
    195
    Симпатии:
    23
    Fatal error: Call to a member function get() on a non-object in Z:\home\demo.ru\www\administrator\templates\khepri\login.php on line 35
    вот такое сообщение у меня начало выводить на 2 сайтах
    (на денвере у меня их 4 остальные 2 нормально работают)
    не могу понять почему
    при чем я ни чего не делал
    вчера вечером нормально запускались а вот теперь не хотят
    поднимал бекапы и все равно такое же
    пытался переставить на разные версии денвер и все тоже самое
    и ни как не могу разобраться
    пожалуйста ПОМОГИТЕ
     
  2. zavrus

    zavrus

    Регистр.:
    29 май 2009
    Сообщения:
    174
    Симпатии:
    78
    открой файл login и посмотреть 35 строке что написано .. если там все хоккей значит у тебя модули конфликтуют
     
  3. oncat

    oncat Создатель

    Регистр.:
    7 мар 2009
    Сообщения:
    26
    Симпатии:
    6
    Насколько я вижу, конфликт возникает в файле login который идет в шаблоне админцентра Khepri Blue Icons.
    Как самый простой выход, можно попробовать сменить этот шаблон админки на дефолтный. Должно помочь. Ну и посмотреть что там в 35 строке...
    Кроме того ссылка на ошибку какая то кривая (\khepri \login.php) - я имею ввиду пробел перед слэшем после khepri.
    В общем криво стоит шаблон админки имхо. Или переустановите или снесите на дефолтный.
     
  4. 3ner

    3ner

    Регистр.:
    21 июн 2009
    Сообщения:
    757
    Симпатии:
    197
    Абсолютно такая же ситуация с Joomla и Денвером на винде, товарищ банально восстановил из бэкапа и поправил ссылки.
    Оригинал тут:
    http://joomlaforum.ru/index.php?topic=100997.0
     
  5. nikoter

    nikoter

    Регистр.:
    29 май 2008
    Сообщения:
    195
    Симпатии:
    23
    в том то и дело что все нормально с этим шаблоном
    это как раз и есть дефолтный шаблон админки для жомлы
    как я писал бэкапы не помогали

    в общем я снес винду поставил заново все и начало работать
    в чем была причина я так и не разобрался
     
  6. komodo

    komodo Создатель

    Заблокирован
    Регистр.:
    7 июл 2008
    Сообщения:
    20
    Симпатии:
    1
    берется отладчик и проверяется :)
    думаю проблема возникла после установки какого-то нового компонента или модуля
     
Статус темы:
Закрыта.