1. Уважаемые пользователи, прежде чем ответить в теме или создать новую,
    внимательно ознакомьтесь с правилами раздела

    Кому лень работать или руки не оттуда - пользуйтесь услугами специалистов
  2. Не задавайте глупых вопросов "Посоветуйте какой-нибудь компонент.."

    Есть JED!!! Ищите там!!!

Кто мог бы написать небольшой мануал по переделке компонента J1.0 в компонент J1.5?

Тема в разделе "Joomla", создана пользователем sigmalion, 17 фев 2010.

Информация :
  • Уважаемые пользователи, прежде чем ответить в теме или создать новую, внимательно ознакомьтесь с правилами раздела
  • Не задавайте глупых вопросов "Посоветуйте какой-нибудь компонент.." Есть JED!!! Ищите там!!!
  • Аналоги ищите там же - на JED!!!
  • Новая версия? - У кого будет - тот выложит!
Статус темы:
Закрыта.
Модераторы: arman29, DMS, Genk0
  1. sigmalion

    sigmalion Создатель

    Регистр.:
    27 янв 2010
    Сообщения:
    13
    Симпатии:
    0
    Ребята, кто сталкивался с такой проблемой?
    Интересуют в первую очередь основные различия между компонентами J1.0 и J1.5
    Краткий обзор, что интересует, есть один очень хороший компонент под J1.0, он нулед. Компонент поиска с фильтрацией по категориям, разделам, разные выводы найденых материалов и т.п. Компонент Search&Archive. Под версию 1.5 сколько не бился нуледа не нашел, только платная версия компонента.

    Добавлено через 11 минут
    Чтобы упростить задачу, может быть кто-то встречался с компонентом Search&Archive под J1.5 нуленую?
     
  2. svetkin

    svetkin Постоялец

    Регистр.:
    12 мар 2009
    Сообщения:
    99
    Симпатии:
    15
    на сколько я знаю, в J1.5 есть плагин - Legacy, он для совместимости с J1.0
     
  3. sigmalion

    sigmalion Создатель

    Регистр.:
    27 янв 2010
    Сообщения:
    13
    Симпатии:
    0
    Не, не работает, в том то и дело, компоненты работают в legacy когда они под него расчитаны.

    Добавлено через 26 минут
    Ребята/девчата, может у кого есть компонент Search/Archive для ветки 1.5 нуленый? Выложите пожалуйста, все что можно уже облазил не могу найти, очень нужен
     
  4. svetkin

    svetkin Постоялец

    Регистр.:
    12 мар 2009
    Сообщения:
    99
    Симпатии:
    15
    Посмотри здесь, у меня сейчас нет доступа, проверить не могу...
     
  5. sigmalion

    sigmalion Создатель

    Регистр.:
    27 янв 2010
    Сообщения:
    13
    Симпатии:
    0
    Это как раз тот, который я качал, он под 1.0 ставится только

    Добавлено через 10 минут
    Под 1.5 оно вообще не ставится с этого архива, подправил установочные xml она с трудом и кряхтя поставилась, изменил запросы к бд на нужные, вроде делает вид что работает но все равно не работает(((
     
  6. rw4lll

    rw4lll Писатель

    Регистр.:
    8 дек 2007
    Сообщения:
    5
    Симпатии:
    0
    Я как то задавался вопросом переделать один редкий компонент под j1.5 и так и не довел дело до конца. Проблема в том, что вся структура компонента в j1.5 полностью другая. Если в шаблоне можно заменить пару строк-и заработает, то в компонентах 1.0 и 1.5 версии совершенной разный принцип-читай в 1.5 модель-вьювер контроллер. Есть два варианта: либо попробовать через легаси мод (не рекомендую, уж очень он систему грузит да и часто косячит), либо найти аналог на j1.5 .Либо попросить когонибудь во фрилансе.
     
Статус темы:
Закрыта.