[Help] Указываются неверные УРЛ, как пофиксить?

Тема в разделе "vBulletin", создана пользователем pierrevk, 12 фев 2010.

Статус темы:
Закрыта.
  1. pierrevk

    pierrevk Постоялец

    Регистр.:
    22 сен 2009
    Сообщения:
    59
    Симпатии:
    5
    Помогите исправить ошибку!
    Форум Vbulletin установлен на поддомене, но ставил своими кривыми руками, и засунул его еще и в поддиректорию.

    сейчас форум работает по адресу forum.site.ru/forum/index.php и может загружаться при самом простом обращении к нему - forum.site.ru

    Если пользователи запрашивают восстановление пароля, или же пишут жалобу на сообщение, на почту приходит письмо для восстановления пароля - где требуется пройти по ссылке, или же письмо-абуза администратору форума со ссылкой на тему и некорректное сообщение.

    В приходящем письме ссылки на сообщения указаны имеют вид:
    forum.site.ru/showthread.php?p=13947#post13947
    переход по такой ссылке дает 404,

    ссылки должны иметь вид:
    forum.site.ru/forum/showthread.php?p=13947#post13947

    То есть в связи с тем, что я когда-то установил форум в поддиректорию - вылез /forum/ в адресе, который в письмах упорно игнорируется.
    Как бы это вылечить, народ?
     
  2. Axom

    Axom

    Регистр.:
    25 апр 2007
    Сообщения:
    320
    Симпатии:
    94
    А в настройках названия сайта убрал /forum/ ? :)
     
    pierrevk нравится это.
  3. pierrevk

    pierrevk Постоялец

    Регистр.:
    22 сен 2009
    Сообщения:
    59
    Симпатии:
    5
    У меня в настойка в админ. панели написано:
    Я, честно говоря, думал это адрес, по которому я хочу, чтобы люди заходили.
    В самом деле, неприятно же набирать лишний /forum/
    Сейчас не трогаю, ближе к ночи, как треп рассосется, попробую всунуть туда /forum/

    Добавлено: Ура, спасибо Ахом, работает!
     
Статус темы:
Закрыта.