1. Важное и срочное обновление IPB 3.4.5 - https://nulled.cc/threads/243375/

[Помощь] 2.3.6 -> 3.0.5 | неверное определение версии

Тема в разделе "IPB", создана пользователем raven4eg, 6 фев 2010.

Статус темы:
Закрыта.
Модераторы: Maybe
  1. raven4eg

    raven4eg Бесяцая птича

    Регистр.:
    14 дек 2007
    Сообщения:
    151
    Симпатии:
    19
    Версия IPB: 2.3.6 nulled by непомню, вроде DAVIDOFF
    Ошибка проявляется на: 3.0.4, 3.0.5 nulled by Maybe.
    Итак.
    Решился таки проапгрейдится на 3.0.5, всё бы оно хорошо, только вот апдейтер определяет версию форума, как 1.3.x, а не 2.3.x, соответственно пытается апгрейдить с версии 1.3.х, а я боюсь, что это может привести к неприятным и неожиданным последствиям.
    Немного попытался покурить php файлы апгрейдера, так и не допёр откуда он берёт версию установленного форума.
    Собсно как заставить апгрейдер определить версию верно? Откуда он её берёт?
    p.s. проблема явно в уже установленном форуме и том, что я там наколдовал (зуб даю - не помню чего я с ним творил).
     
  2. $iD

    $iD Постоялец

    Заблокирован
    Регистр.:
    23 дек 2006
    Сообщения:
    1.006
    Симпатии:
    175
    Делаешь бэкап, заливаешь на локалхост - апгрейдишь и смотришь что получилось.
     
  3. raven4eg

    raven4eg Бесяцая птича

    Регистр.:
    14 дек 2007
    Сообщения:
    151
    Симпатии:
    19
    Я и так делаю всё на локальной машине. И уже раз 5 туда сюда конвертировал, удалял, перезаливал базу в 200 метров, а это надоедает, ибо на моём тазике происходит медленно.
    Да, кстати, апгрейд не проходит до конца, выпадает в mysql-error и дальше отказывается работать.

    Всё так же ожидаю мыслей по решению проблемы с определением версии.
     
  4. raven4eg

    raven4eg Бесяцая птича

    Регистр.:
    14 дек 2007
    Сообщения:
    151
    Симпатии:
    19
    Решение найдено

    Код:
    DROP TABLE IF EXISTS `ibf_upgrade_history`;
    CREATE TABLE `ibf_upgrade_history` (
      `upgrade_id` int(10) NOT NULL auto_increment,
      `upgrade_version_id` int(10) NOT NULL default '0',
      `upgrade_version_human` varchar(200) NOT NULL default '',
      `upgrade_date` int(10) NOT NULL default '0',
      `upgrade_mid` int(10) NOT NULL default '0',
      `upgrade_notes` mediumtext,
      `upgrade_app` varchar(32) NOT NULL default 'core',
      PRIMARY KEY  (`upgrade_id`)
    ) ENGINE=MyISAM  DEFAULT CHARSET=utf8;
    INSERT INTO `ibf_upgrade_history` (`upgrade_id`, `upgrade_version_id`, `upgrade_version_human`, `upgrade_date`, `upgrade_mid`, `upgrade_notes`, `upgrade_app`) VALUES
    (1, 23004, '2.3.1', 0, 0, '', 'core'),
    (2, 23005, '2.3.2', 1250504732, 0, NULL, 'core'),
    (3, 23006, '2.3.3', 1250504734, 0, NULL, 'core'),
    (4, 23007, '2.3.4', 1250504737, 0, NULL, 'core'),
    (5, 23008, '2.3.5', 1250504742, 0, NULL, 'core'),
    (6, 23009, '2.3.5', 1250504744, 0, NULL, 'core'),
    (7, 23010, '2.3.6', 1250504749, 0, NULL, 'core');
    решение найдено на CSO, спасибо Ritsuka.
     
Статус темы:
Закрыта.