Проблема с кодировкой при переносе на другой хостинг

Тема в разделе "ExpressionEngine", создана пользователем sergsam1, 4 фев 2010.

Статус темы:
Закрыта.
  1. sergsam1

    sergsam1 Создатель

    Регистр.:
    16 янв 2009
    Сообщения:
    33
    Симпатии:
    0
    Ничего не понимаю, перепробовал по-всякому сайт после переноса все равно весь в кракозяблах.
    Пробовал и Sypex Dumper и просто в phpMyadmin импортировать дамп никак не получается.
    Кто знает как решить проблему?
     
  2. Yozik

    Yozik

    Регистр.:
    5 дек 2007
    Сообщения:
    238
    Симпатии:
    65
    Проверь соответствие кодировки phpMyAdmin на хостинге. Кодировка файла дампа должна соответствовать кодировке базы.
     
  3. sergsam1

    sergsam1 Создатель

    Регистр.:
    16 янв 2009
    Сообщения:
    33
    Симпатии:
    0
    Вобщем у меня в колонке "Сравнение" в phpMyadmin на старом хостинге стоит cp1251_general_ci.
     
  4. budulay

    budulay

    Регистр.:
    8 апр 2006
    Сообщения:
    283
    Симпатии:
    87
    переведи сначала все в utf8 а потом переноси, на eeclub.ru есть много тем по поводу переноса и преобразования в другую кодировку
     
  5. Николай

    Николай Постоялец

    Регистр.:
    4 дек 2006
    Сообщения:
    92
    Симпатии:
    21
  6. supersonic

    supersonic Создатель

    Регистр.:
    2 май 2007
    Сообщения:
    12
    Симпатии:
    1
    Очень все просто делается с помощью SypexDumper.
    Кодировка базы в Expressionengine Latin1
    Делай на старом хостинге экспорт в Latin1
    Потом на новом импортируй в Utf-8 и все отлично будет :)
     
Статус темы:
Закрыта.