[Помогите] Проблеммы при удаленной публикации по протоколу XML-RPC

Тема в разделе "Wordpress", создана пользователем soll2307, 1 янв 2010.

Статус темы:
Закрыта.
Модераторы: DzSoft, Sorcus
  1. soll2307

    soll2307 Создатель

    Регистр.:
    27 июл 2009
    Сообщения:
    36
    Симпатии:
    3
    уже который день рою интернет на предмет почему при удаленной публикации по протоколу XML-RPC в wordpress через блог-клиент.
    Из : <p>пост пример</p>
    <p> </p>
    <p>пост</p>
    <p> </p>
    <p>пост</p>
    делает такое, уничтожая треугольные скобки: pпост пример/p p#160;/p pпост/p p#160;/p pпост/p
    или вообще не заходит на блог, требуя пароль и его тут же бракует.
    До переезда было все ок. Причем на всех wordpress (2.6 и 2.8) проблемы с удаленной публикацией. Что тут может быть? Если публикации идет с админки, то все нормально.
     
  2. BadMotherFucker

    BadMotherFucker Модератор (Core Team)

    Регистр.:
    13 ноя 2009
    Сообщения:
    784
    Симпатии:
    560
    С помощью какого именно программного блог-клиента вы публикуете записи в wordpress?
     
  3. DimaZ12

    DimaZ12 Постоялец

    Регистр.:
    9 окт 2009
    Сообщения:
    70
    Симпатии:
    8
    Там нужно тему править..
     
  4. soll2307

    soll2307 Создатель

    Регистр.:
    27 июл 2009
    Сообщения:
    36
    Симпатии:
    3
    Windows Live Writer- этот блог-клиент. Общем проблему решил- просто методом проб и ошибок подобрал хостинг на котором такой проблемы нет для моих сайтов. И убрал некоторые плагины.
     
  5. clauzd

    clauzd Создатель

    Регистр.:
    9 апр 2008
    Сообщения:
    14
    Симпатии:
    0
    Попробуйте ЧПУ отключить. Мне лично помогло.
     
  6. soll2307

    soll2307 Создатель

    Регистр.:
    27 июл 2009
    Сообщения:
    36
    Симпатии:
    3
    если чпу отключить, то индексация в поисковиках пропадет- сайты не новые и проблема возникла, когда переносил все на другой хостинг.
     
Статус темы:
Закрыта.