1. Важное и срочное обновление IPB 3.4.5 - https://nulled.cc/threads/243375/

Пара проблем с IPB 2.2.x и их решения

Тема в разделе "IPB", создана пользователем BadLand, 16 май 2007.

Статус темы:
Закрыта.
Модераторы: Maybe
  1. BadLand

    BadLand Прохожие

    Столкнулся с 2-мя проблемами, нашел их решения, можеткому прингодится, что б не гуглить по чем зря :)

    1) Для удаления бага с отрицательными личными сообщениями на форуме (сам сталкивался, действительно такой баг есть)

    ALTER TABLE `ibf_members` CHANGE `new_msg` `new_msg` TINYINT( 2 ) UNSIGNED NULL DEFAULT '0';

    2) У меня была проблема под линуксом с библиотекой GD. Не пересобиралась с поддержкой jpeg (или я криво пересобирал, что тоже может быть :)). Я думаю многие сталкивались, что ресайз картинок в галерее не работает и при добавлении большой картинки в галерею видишь белую пустую страницу. Здесь решения два:

    2.1) Пересобрать GD с поддержкой jpeg-6b. Скачать от сюда ftp://ftp.uu.net/graphics/jpeg/, а затем перекомпилировать GD на использование jpeg-6b. Также
    вы должны будете также скомпилировать PHP с опцией --with-jpeg-dir=/path/to/jpeg-6b. И указать правильный путь в админке форума к GD. P.S. Это при условии что у вас GD больше версии 1.6 по-моему =). Ну можно взглянуть на сайте самой GD с какой она версии не поддерживает jpeg.

    2.2) Можно обойтись малой кровью и выставить Image Magic в настройках галереи и обычно он располагается по этому адресу: /usr/bin/. Короче там где лежит программа convert.

    У меня в итоге заработало со вторым пунктом. :)
     
  2. Avalanch

    Avalanch ТоЛеГ & ТоПеГ

    Регистр.:
    9 янв 2007
    Сообщения:
    1.136
    Симпатии:
    524
    Ммм, по - моему эти ошибки не во всех версиях ИПБ серии 2.2.х . Покрайне менее в версии 2.2.2 не встречал.
     
  3. Avalanch

    Avalanch ТоЛеГ & ТоПеГ

    Регистр.:
    9 янв 2007
    Сообщения:
    1.136
    Симпатии:
    524
    Да, баг с приватными сообщения действительно есть. Просто сообщения не удалял приватные, после удаление было такое "-1". Спасибо сказал.
     
  4. dmntr

    dmntr Прохожие

    никто не знает, как подлючить модуль галлереи при php safemode=off:nezn:
     
  5. Avalanch

    Avalanch ТоЛеГ & ТоПеГ

    Регистр.:
    9 янв 2007
    Сообщения:
    1.136
    Симпатии:
    524
    А что там такое мешает тебе включить галерею при safe mod ?
     
  6. MaoDzeDunUA

    MaoDzeDunUA Создатель

    Регистр.:
    5 апр 2007
    Сообщения:
    21
    Симпатии:
    1
    ИМХО, никак
    нужно сейф_моде включать
     
  7. Suslik

    Suslik Прохожие

    В каком смысле подключить? Нужно просто напросто запустить скрипт установки галереи и следовать инструкциям помощника.
     
  8. andrsp

    andrsp Писатель

    Регистр.:
    8 апр 2007
    Сообщения:
    7
    Симпатии:
    1
    спасибо за полезные советы, с отрицательными сообщениями помогло
     
  9. tov_Me

    tov_Me Постоялец

    Регистр.:
    7 апр 2007
    Сообщения:
    93
    Симпатии:
    6
    Я понимаю, когда возникают проблемы при safemode on, но с сейфомод офф какие вообще могут быть проблемы? есть же интсаллер.
     
  10. BadLand

    BadLand Прохожие

    Я догадываюсь, что не все здесь программисты, но вероятно многие знают PHP на уровне плинтуса, для них посвещается:

    Столкнулся с проблемой в 2-х модах: форум показывает топики в нужной кодировке, а моды обращаясь к базе (обычно UTF8 - вывод в cp1251) выводят мессаги в виде ????? ?? ?????.

    Решение простое: в скрипте [вашем моде] перед запросом к базе mysql_query вставить такую строчку: mysql_query("set CHARACTER SET cp1251");

    Т.е., например, было так:

    Код:
    $getposts = mysql_query("SELECT posts, last_poster_name, ..... ")
    Стало так:
    Код:
    mysql_query("set CHARACTER SET cp1251");
    $getposts = mysql_query("SELECT posts, last_poster_name, ..... ")
    Отцы, не пугайтесь =), все с чего-то начинают :) для меня это была небольшая, но проблема :) :)
     
Статус темы:
Закрыта.