Снова дампы ))))

Тема в разделе "Администрирование серверов", создана пользователем lift, 13 ноя 2009.

Статус темы:
Закрыта.
Модераторы: mefish, stooper
  1. lift

    lift Читатель

    Заблокирован
    Регистр.:
    1 июл 2007
    Сообщения:
    2.226
    Симпатии:
    1.378
    База MySQL в ср1251, размером около 35 гигов.
    Дамплю симплекс дампером и нифига, вчера поставил в обед дампиться, ночью чето глюкнуло и процесс оборвался, сейчас 6 часов висит дампиться и гето 20% только.
    Учитывая, что база создавалась с технической точки зрения за меньший срок (5-6 часов) то вообще непонятно чего так долго дампиться. Сервак мощный по самое немогу, мускуль настроен на даже бОльшие размеры бази нет проблем вообще.
    Если сливать через mysqldump то там кодировка юникод, у меня ср1251 и не особо улыбается получить такой дамп. Потыкался там с принудительным указанием кодировки и чет как то глухо получилось. да и вообще с этой тулзой работал 1-2 раза и впечатления самые плохие.
    PhpMyAdmin тоже не вариант, регать 35 гигов на 65мб куски, даже с учетом запаковки... Вообще слабореально.
    Тулза для дампа от энтерпрайз мускуля была у меня но я так и не смог ей подконнектиться к мускулю на локалхост и потер ее в итоге.
    Собственно если кто знает чем еще сдампить нормально и за вменяемый срок (желательно) то готов выслушать.
    p.s. Платформа win 2k8 x64
    p.p.s. Посмотрел сейчас, ночью дампилось и оборвалось на 5.7 гига. Тоесть даже 16% за 12+ часов (точно не знаю сколько было так как спал. За 12 часов можно 2 такие базы еще сделать а тут дампиться только 16%.
     
  2. studentpm

    studentpm

    Регистр.:
    8 ноя 2006
    Сообщения:
    184
    Симпатии:
    132
    Простите конечно, но лучше mysqldump ничего нет, "вы просто не умеете его готовить" (с)
    Код:
    mysqldump --user=my_user --password=my_pass  --default-character-set=cp1251 --allow-keywords --create-options --complete-insert db_name | gzip > ./dbName.sql.gz

    3 гиговая база жмется за 3-5 минут.
     
    lift нравится это.
  3. lift

    lift Читатель

    Заблокирован
    Регистр.:
    1 июл 2007
    Сообщения:
    2.226
    Симпатии:
    1.378
    studentpm
    Только всетаки наверное
    Код:
    mysqldump --user=my_user --password=my_pass  --default-character-set=cp1251 --allow-keywords --create-options --databases db_name | gzip > ./dbName.sql.gz
    :)
    Странно но сдампило другую (меньшую) базу нормально. Я как не пробывал указать кодировку не хотело слушаться меня, а тут вроде послушалась ))) Без сжатия дампил правдо, в простой файл. Кодировка не слетела.
    И кстати вот так
    Код:
    mysqldump --user=my_user --password=my_pass  --default-character-set=cp1251 --databases db_name | gzip > ./dbName.sql.gz
    сдампило тоже самое байт в байт так что ключи видимо лишние эти.
    Сейчас запущу дампиться сабжевую базу, попробую и отпишусь.
     
  4. studentpm

    studentpm

    Регистр.:
    8 ноя 2006
    Сообщения:
    184
    Симпатии:
    132
    --databases вообще не обязательный параметр =)
     
  5. lift

    lift Читатель

    Заблокирован
    Регистр.:
    1 июл 2007
    Сообщения:
    2.226
    Симпатии:
    1.378
    Если сделать копипаст того что написал ты то не дампиться вообще ))))
    Ладно, собственно сдампить получилось, 54 минуты. И сиплекс залил назад этот дамп еще за 86. Проблема полностью исчерпана, спасибо за помощ )))
     
  6. despainer

    despainer

    Регистр.:
    15 фев 2008
    Сообщения:
    615
    Симпатии:
    168

    [mysqldump]
    quick
    max_allowed_packet = 16M увеличить до 256-512 мб

    [mysql]
    no-auto-rehash
    # Remove the next comment character if you are not familiar with SQL
    #safe-updates

    [myisamchk]
    key_buffer_size = 8M увеличить до 32
    sort_buffer_size = 8M увеличить до 16-32

    [mysqlhotcopy]
    interactive-timeout

    mysqldump -u usename -p pass имя базы >файл дампа
     
  7. lift

    lift Читатель

    Заблокирован
    Регистр.:
    1 июл 2007
    Сообщения:
    2.226
    Симпатии:
    1.378
    Спасибо. Реально кстати. Я когда то давно перелопатил пол мускуль.ком и рунета в поисках материалов по настройке. Только сейчас с таккими настройками не заведеться у меня мускуль :) Маловато будет )))
    :)
    а параметр max_allowed_packet вообще прописывать имхо больше 64м смысла нет так как longtext как раз столько вмещает по максимому и за раз 1 пакет сделать больше будет очень сложноно. БСЭ в тексте 56 мегов всего
    ну а
    сдампит в utf8 что в моем случае не приемлемо.

    Собственно вопрос уже решен. Если кто то сможет залить и слить дампы на 35 гигов бстрее чем в моем предидущем посте только с изменением натроек мускуля... Блин, я честно не представляю насколько для этого надо шарить в мускуле :) Да и не думаю что мне оно нужно на самом деле.
    Собственно вопрос решен уже 14 числа. Тема не актуальна. Спасибо всем за помощ.
     
Статус темы:
Закрыта.