Как работать с everydns.com или другой в бесплатный dns

Тема в разделе "Домены", создана пользователем grixann, 13 ноя 2009.

Статус темы:
Закрыта.
Модераторы: Aste
  1. grixann

    grixann

    Регистр.:
    8 фев 2009
    Сообщения:
    443
    Симпатии:
    41
    Вобщем домены с горем пополам добавил, но они все направлены в корень сайта /var/www/
    А мне нужно чтобы домены работали как разные сайты на apache2

    настроил на apache2 виртуальные хосты а результата ноль, домены всеравно направлены в корень сайта

    PHP:
    #----bluebasin.ru

    <VirtualHost bluebasin.ru:81>
    ServerAdmin webmaster@bluebasin.ru
    ServerName bluebasin
    .ru
    DocumentRoot 
    "/var/www/bluebasin.ru"
    ScriptAlias /cgi"/var/www/bluebasin.ru/cgi"
    ErrorLog /var/www/bluebasin.ru/error.log
    CustomLog 
    /var/www/bluebasin.ru/access.log common
    </VirtualHost>
    Как настроить правельно ? чтобы домены работали на одном сервере но как разные сайты ?
    Может это проблема в бесплатном dns сервере ? подскажите хороший бесплатны и расскажите как его настроить
    За ранее спасибо
     
  2. tostrss

    tostrss

    Регистр.:
    16 окт 2007
    Сообщения:
    771
    Симпатии:
    217

    замени на

    Да и порт вместо 81, скорее всего должен быть 80
     
  3. studentpm

    studentpm

    Регистр.:
    8 ноя 2006
    Сообщения:
    184
    Симпатии:
    132
    Дело точно не в настройках dns. Правь конфиг апача. Что-бы не ждать обновления днс зон пропиши в hosts у себя на машине привязки доменов к ip сервера.
     
  4. grixann

    grixann

    Регистр.:
    8 фев 2009
    Сообщения:
    443
    Симпатии:
    41
    Почему поставил 81 порт у меня занят 80 порт на vds OC debian
    Как правально создать виртуальный хост в apache2 ? для debian ninimal 5.4 ?
     
  5. tostrss

    tostrss

    Регистр.:
    16 окт 2007
    Сообщения:
    771
    Симпатии:
    217
    Ну если у тебя апач там поднят, значит в доменах надор указывать 80 порт.
    Ты правильно создал хост, а что подправить я тебе уже сказал.
     
  6. studentpm

    studentpm

    Регистр.:
    8 ноя 2006
    Сообщения:
    184
    Симпатии:
    132
    Код:
    NameVirtualHost *:81
    <VirtualHost *:81>
    DocumentRoot "/var/www/test.ru/www"
    ServerName test.ru
    <Directory "/var/www/test.ru/www">
    AllowOverride All
    allow from all
    Options -Indexes FollowSymLinks
    </Directory>
    </VirtualHost>
    <VirtualHost *:81>
    DocumentRoot "/var/www/test2.ru/www"
    ServerName test2.ru
    <Directory "/var/www/test2.ru/www">
    AllowOverride All
    allow from all
    Options -Indexes FollowSymLinks
    </Directory>
    </VirtualHost>
    
     
  7. grixann

    grixann

    Регистр.:
    8 фев 2009
    Сообщения:
    443
    Симпатии:
    41
    После токо как все сделал по инструкции от
    PHP:
    http://www.debian-administration.org/articles/412
    толь замениль корневую директорию с /home/www на /var/www

    И получил ошибку
    PHP:
    Restarting web serverapache2[Fri Nov 13 16:51:45 2009] [warnNameVirtualHost *:80 has no VirtualHosts
    [Fri Nov 13 16:51:45 2009] [warn
    NameVirtualHost *:80 has no VirtualHosts... waiting [Fri Nov 13 16:51:46 2009
    [
    warnNameVirtualHost *:80 has no VirtualHosts
    [Fri Nov 13 16:51:46 2009] [warnNameVirtualHost *:80 has no VirtualHosts 
    Как исправить ? пробовал убрать назначения порта а оставить просто * и получил
    PHP:
    Restarting web serverapache2[Fri Nov 13 16:54:53 2009] [warnNameVirtualHost *:0 has no VirtualHosts
    [Fri Nov 13 16:54:53 2009] [warnNameVirtualHost *:80 has no VirtualHosts
     
    ... waiting [Fri Nov 13 16:54:54 2009] [warnNameVirtualHost *:0 has no VirtualHosts
    [Fri Nov 13 16:54:54 2009] [warnNameVirtualHost *:80 has no VirtualHosts
    .
    Как исправить и запустить этот виртуальный хост ?
    PHP:
    Restarting web serverapache2[Fri Nov 13 16:58:11 2009] [warnNameVirtualHost *:80 has no VirtualHosts
    [Fri Nov 13 16:58:11 2009] [warnNameVirtualHost *:80 has no VirtualHosts
     failed
    !
    Я ТАК И НЕ ПОНЯЛ ФАЙЛ С КАКИМ СОДЕРЖАНИЯМ Кидать в /etc/apache2/sites-enabled/ кинул точно такой как и в /etc/apache2/sites-available/
     
  8. help40

    help40

    Регистр.:
    1 окт 2006
    Сообщения:
    252
    Симпатии:
    26
    к сожаление не използую дебиан , но у тебя думаю и другая ошибка есть
    напиши свой ИП вот примерно так

    Код:
    NameVirtualHost 69.73.163.11
    <VirtualHost 69.73.163.11:80>
    
     
  9. grixann

    grixann

    Регистр.:
    8 фев 2009
    Сообщения:
    443
    Симпатии:
    41
    Попробывал и изменил данные на
    PHP:
    #
    #  We're running multiple virtual hosts.
    #
    NameVirtualHost 188.40.161.19
    и заполнил конфиг виртуального сервера
    PHP:
    #
    #  bluebasin.ru (/etc/apache2/sites-available/bluebasin.ru)
    #
    <VirtualHost 188.40.161.19:80>
            
    ServerAdmin webmaster@bluebasin.ru
            ServerName  www
    .bluebasin.ru
            ServerAlias bluebasin
    .ru

            
    # Indexes + Directory Root.
            
    DirectoryIndex index.html
            DocumentRoot 
    /var/www/bluebasin.ru/htdocs/

            
    # CGI Directory
            
    ScriptAlias /cgi-bin/ /var/www/bluebasin.ru/cgi-bin/
            <
    Location /cgi-bin>
                    
    Options +ExecCGI
            
    </Location>


            
    # Logfiles
            
    ErrorLog  /var/www/bluebasin.ru/logs/error.log
            CustomLog 
    /var/www/bluebasin.ru/logs/access.log combined
    </VirtualHost>
    И в итоге получил ошибку
    PHP:
    Restarting web serverapache2[Fri Nov 13 20:45:50 2009] [warnNameVirtualHost 188.40.161.19:0 has no VirtualHosts
    [Fri Nov 13 20:45:50 2009] [warnNameVirtualHost *:80 has no VirtualHosts
     
    ... waiting [Fri Nov 13 20:45:52 2009] [warnNameVirtualHost 188.40.161.19:0 has no VirtualHosts
    [Fri Nov 13 20:45:52 2009] [warnNameVirtualHost *:80 has no VirtualHosts
    Как исправить и запустить?
     
  10. mglushakov

    mglushakov Создатель

    Регистр.:
    26 июл 2008
    Сообщения:
    27
    Симпатии:
    2
    Скорее всего не правильно прописал VirtualHost. В главном конфиге нужно подключать файлы httpd_vhost.conf если не ошибаюсь, далее там по умолчанию показан пример создания. Вот мой:

    <VirtualHost IP:80>
    ServerName domain
    ServerAlias domain
    ServerAdmin webmaster@local
    DocumentRoot /home/www/private_html
    ScriptAlias /cgi-bin/ /home/www/public_html/cgi-bin/

    UseCanonicalName OFF

    CustomLog /var/log/httpd/domains/domain.bytes bytes
    CustomLog /var/log/httpd/domains/domain.log combined
    ErrorLog /var/log/httpd/domains/domain.error.log

    <Directory /home/www/private_html>
    Options +Includes -Indexes

    php_admin_flag engine ON
    <IfModule !mod_php6.c>
    php_admin_flag safe_mode ON
    </IfModule>
    php_admin_value sendmail_path '/usr/sbin/sendmail -t -i -f admin@local'
    </Directory>
    </VirtualHost>
     
Статус темы:
Закрыта.