[Помощь] Проблема с объявлением переменной в Vam shop.

Тема в разделе "Интернет-магазины", создана пользователем Ask4morE, 28 авг 2009.

Статус темы:
Закрыта.
  1. Ask4morE

    Ask4morE Создатель

    Регистр.:
    18 янв 2009
    Сообщения:
    38
    Симпатии:
    1
    Добрый день, проблема в следующем:
    Есть файло: product_compare.php,
    Есть файлик: product_parameters.html - его содержимое:
    HTML:
    
    {*b1te DONE*}
    {config_load file="$language/lang_$language.conf" section="product_compare"}
    <table width="100%" border="0" cellpadding="0" cellspacing="0">
    	{foreach name=aussen item=parameters_data from=$parameters}
    	<tr>
    		<td {if $parameters_data.is_group}colspan="3"{/if}>
    {$parameters_data.parameters_name}{$products_name}</td>
    		{if $parameters_data.parameters_values}
    		{foreach name=aussen item=values from=$parameters_data.parameters_values}
    		<td>{if $values.value}{$values.value}{else}&nbsp;{/if} </td>
    		{/foreach}
    		{/if}
    	</tr>
    	{/foreach}
    </table>
    
    Собственно, хочу подключить в данный шаблон переменную $products_name, и насколько я понял делается это с помощью выше указанного php файлика...
    Если кто-то может подсказать, как это реализовать, буду очень благодарен.
    С ув. Евгений.
     
  2. p1kka

    p1kka Постоялец

    Регистр.:
    12 авг 2009
    Сообщения:
    76
    Симпатии:
    22
    Думаю правильнее было бы озвучить задачу, которую вы хотите выполнить. Вдруг существует готовое решение, и дело совсем не в этой переменной. Тем более, насколько мне известно, в *.html файлах шаблонов переменные не задаются.
     
  3. Ask4morE

    Ask4morE Создатель

    Регистр.:
    18 янв 2009
    Сообщения:
    38
    Симпатии:
    1
    Вы абсолютно правы. Задать переменную необходимо в пхп-скрипте.
    А в шаблоне только использовать. И мне необходима именно эта переменная,($PRODUCTS_NAME), что бы указывать название товара.
    А product_parameters.html это такой себе модуль, подключаемый к product_info.html(В продукт инфо переменная есть и работает, а в этом модуле нет) Самостоятельно подключить не могу :(
     
Статус темы:
Закрыта.