Помощь Помогите правильно обновится

Тема в разделе "DLE", создана пользователем Izrael, 25 авг 2009.

Информация :
Актуальная версия DataLife Engine 12.0
( Final Release v.12.0 | Скачать DataLife Engine | Скачать 12.0 demo )
Нужно ли обновляться | Как обновиться | Изменения в шаблонах
> Нет русских символов <
[Приватная тема DLE (Все подробности в ЛС к модератору раздела)]

Версии 11.3 и ниже - уязвимы!

Локализации | F.A.Q. | Внешний вид
Правила раздела | Правила форума
Обсуждение хайда карается баном!
В каждом сообщении указывайте версию DLE, которого они касаются!
Статус темы:
Закрыта.
Модераторы: killoff
  1. Izrael

    Izrael

    Регистр.:
    12 фев 2008
    Сообщения:
    452
    Симпатии:
    57
    Привет, хотел бы спросить.. возможно ли обновиться с dle 7.3 на 8,2 ?
    Такой вопрос, не потеряю ли я своих пользователей и новости?
    2, Как быть с форумом? у меня стоит DLE Forum v.2.2
    3, Что будет с моими модулями опять по новой ставить их ?
     
  2. chibit

    chibit Life sucks.

    Регистр.:
    4 дек 2007
    Сообщения:
    419
    Симпатии:
    285
    1) Читай мануал, там есть инструкция по обновлению (удаляешь все папки, кроме тех, которые в мануале описаны), заливаешь новые файлы, запускаешь обновление и все :)
    2) скорей всего придется обновить форум до более новой версии
    3) Да, по новой (но только в движке, в базе все данные сохранятся от модулей)
     
  3. mif

    mif Создатель

    Регистр.:
    17 ноя 2006
    Сообщения:
    10
    Симпатии:
    1
    Ничего удалять лучше не надо, а то махнешь, что не надо. Заливаешь файлы из архива на сервер и следуешь инструкции из update.html
    1. Если будешь все делать правильно, то ничего из базы данных не потеряешь. ЛУчше перед обновлением сделать бэкап базы данных.
    2. Форум тоже лучше обновить во избежания ошибок. Актуальная версия сейчас 2.4
    3. Т.к. ты на п.1 заменил все старые файлы движка, то все модули придется ставить заново, только учти, что некоторые модули, написанные для версий ниже 8.2 могут некорректно работать в некоторых случаях (адинка не доступна, имя групп не то итд итп)
     
  4. Klepach

    Klepach

    Регистр.:
    31 окт 2008
    Сообщения:
    941
    Симпатии:
    250
    перед обновлением сделай бекап и базы и всех папок с файлами движка на всякий случай, чтоб потом самого себя не кусать.
     
  5. Izrael

    Izrael

    Регистр.:
    12 фев 2008
    Сообщения:
    452
    Симпатии:
    57
    Привет, всем спасибо обновился.... )
    Только вот появилась проблема теперь при добовлении коментария мне пишет
    Hacking attempt!
    а пользователи могут добовлять
     
  6. mif

    mif Создатель

    Регистр.:
    17 ноя 2006
    Сообщения:
    10
    Симпатии:
    1
    видимо, какие-то модули косячат. На голом движке такого не может быть. Попробуй почистить куки для начала и заново залогиниться.
     
  7. Izrael

    Izrael

    Регистр.:
    12 фев 2008
    Сообщения:
    452
    Симпатии:
    57
    почистил куки и не помгло (((
    я еще форум одновил.. значит пользователь может входить на него все нормально а когда я вхожу выдает ошибку

     
  8. mif

    mif Создатель

    Регистр.:
    17 ноя 2006
    Сообщения:
    10
    Симпатии:
    1
    это не ошибка, это код выполняемого запроса :) Приведи целиком ошибку.

    Кстати, после обновления надо кэш очищать. Ты очистил?
     
  9. Izrael

    Izrael

    Регистр.:
    12 фев 2008
    Сообщения:
    452
    Симпатии:
    57
    Почистил хеш.. все ровно такое..
    Я заметил глюки именно на логене админа...
    скрин ошибки во вложении положил
     

    Вложения:

  10. mif

    mif Создатель

    Регистр.:
    17 ноя 2006
    Сообщения:
    10
    Симпатии:
    1
    он говорит, что нет такого параметра is_count в базе данных.
    Ты как форум обновлял? ПО инструкции? В версии 2.4 как раз добавился is_count...

    Выполни все sql-запросы, лежащие в этом файле:
    \engine\forum\install\db_2.4.php
     
Статус темы:
Закрыта.