Как с этим бороться?

Тема в разделе "PHP", создана пользователем shamantc, 22 июл 2009.

Статус темы:
Закрыта.
Модераторы: latteo
  1. shamantc

    shamantc ЗлОй ШаМан

    Заблокирован
    Регистр.:
    3 ноя 2008
    Сообщения:
    651
    Симпатии:
    183
    Здравствуйте запустил скрипт а мне сайт пишет


    Код:
    ОШИБКА!
    Ваш браузер Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; Trident/4.0; Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1) ; RadioClicker LITE; InfoPath.1; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729) не поддерживает объектную модель документа (DOM), либо под него еще не адаптирован чат
    Чат работает в следующих браузерах: Internet Explorer 5.0 и выше скачать (для Windows-систем) 
    Netscape Navigator 7.0 и выше скачать (для Windows, Linux, Mac OS X и других) 
    Mozilla 1.0 и выше скачать (для Windows, Linux, Mac OS X и других) 
    Opera 7.0 и выше скачать (для Windows, Linux, Mac OS X и других)  
    Что такое DOM, и как его можно поставить на ISPmanager (firstvds)
    если что то не так то можете объяснить
     
  2. finerit

    finerit Писатель

    Регистр.:
    19 июл 2009
    Сообщения:
    9
    Симпатии:
    0
    DOM это расширение для PHP. В ISPmanager есть меню расширений PHP, там он и активируется.

    Насчет вашего вопроса касательно работы чата в броузерах, тут уже нужно копать скрипты. Думаю неспроста он не везде работает.
     
  3. KillDead

    KillDead

    Регистр.:
    11 авг 2006
    Сообщения:
    890
    Симпатии:
    558
    Вы читать умеете?:D
    Проблема в браузере. Точнее в JavaScrit (на которм скорее всего работает чат)- это скрипты которые выполняет браузер. Если же браузер старый то он может не поддерживать какие-либо команды.


    Ага, только для для PHP?

    http://ru.wikipedia.org/wiki/DOM
     
  4. shamantc

    shamantc ЗлОй ШаМан

    Заблокирован
    Регистр.:
    3 ноя 2008
    Сообщения:
    651
    Симпатии:
    183
    Можете мне подсказать мануал на русском где можно почитать где и на что мне переписать скрипты потому что это пишет во всех браузерах что в IE 7,8; что в opere, тоже самое и в файрфоксе

    Добавлено через 5 минут
    Можете подсказать какой нибудь JS редактор с подсветкой синтаксиса, который изначально был реализован только на JS
     
  5. KillDead

    KillDead

    Регистр.:
    11 авг 2006
    Сообщения:
    890
    Симпатии:
    558
    Раз во всех браузерах такое- где то в скрипте ошибка. Возможно скрипт неверно определяет версию. Надо найти где скрипт (а это уже не обязательно js) выводит текст "Ваш браузер.." и смотреть при каких условиях он это делает.

    Ещё я бы посоветовал поставить какой-нить отладчк js- Firebug например
     
Статус темы:
Закрыта.